summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 16:48:05 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:40:01 -0500
commit3d512115129e2cea97067d23cb72fea62b70dd39 (patch)
treed891dce76b3cfa2bcb2b4afaf04704fa862da1f6 /recipes-devtools
parentb63d5e8f9d1a6ce468d8c327fbdc6bdcff357ee2 (diff)
downloadmeta-cloud-services-3d512115129e2cea97067d23cb72fea62b70dd39.tar.gz
python-*: switch remaining pypi recipes to use the pypi class
Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. In most cases we are able to drop SRC_URI, however, for some recipes using archived versions of packages we must set PYPI_SRC_URI to overwrite what the pypi class would derive. For example when the archive is a zip and not a tar.gz. In all cases we can drop the defining of 'S' and 'PR' as the pypi class and the PR server will set these correctly. In most cases we can drop SRCNAME. Where needed we instead set PYPI_PACKAGE to overwrite the derived name that the pypi class would otherwise calculate. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-greenlet_0.4.9.bb7
-rw-r--r--recipes-devtools/python/python-pyparsing_2.0.1.bb9
2 files changed, 3 insertions, 13 deletions
diff --git a/recipes-devtools/python/python-greenlet_0.4.9.bb b/recipes-devtools/python/python-greenlet_0.4.9.bb
index fa35fa8..49c2551 100644
--- a/recipes-devtools/python/python-greenlet_0.4.9.bb
+++ b/recipes-devtools/python/python-greenlet_0.4.9.bb
@@ -4,11 +4,8 @@ SECTION = "devel/python"
4LICENSE = "MIT & PSF" 4LICENSE = "MIT & PSF"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \ 5LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
6 file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a" 6 file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
7SRC_URI = "http://pypi.python.org/packages/source/g/greenlet/greenlet-${PV}.tar.gz" 7
8SRC_URI[md5sum] = "00bb1822d8511cc85f052e89d1fd919b" 8SRC_URI[md5sum] = "00bb1822d8511cc85f052e89d1fd919b"
9SRC_URI[sha256sum] = "79f9b8bbbb1c599c66aed5e643e8b53bae697cae46e0acfc4ee461df48a90012" 9SRC_URI[sha256sum] = "79f9b8bbbb1c599c66aed5e643e8b53bae697cae46e0acfc4ee461df48a90012"
10 10
11S = "${WORKDIR}/greenlet-${PV}" 11inherit distutils pypi
12
13inherit distutils
14
diff --git a/recipes-devtools/python/python-pyparsing_2.0.1.bb b/recipes-devtools/python/python-pyparsing_2.0.1.bb
index 32d9ebb..2ef6df9 100644
--- a/recipes-devtools/python/python-pyparsing_2.0.1.bb
+++ b/recipes-devtools/python/python-pyparsing_2.0.1.bb
@@ -4,14 +4,7 @@ SECTION = "devel/python"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a"
6 6
7PR = "r0"
8SRCNAME = "pyparsing"
9
10SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.zip"
11
12SRC_URI[md5sum] = "dc7036a6f1ab01c3baed3d97af8d77c0" 7SRC_URI[md5sum] = "dc7036a6f1ab01c3baed3d97af8d77c0"
13SRC_URI[sha256sum] = "7e1766ee747cca79fe172b670fd53ef58fc55d2b1804fd6c66d857abb62d143a" 8SRC_URI[sha256sum] = "7e1766ee747cca79fe172b670fd53ef58fc55d2b1804fd6c66d857abb62d143a"
14 9
15S = "${WORKDIR}/${SRCNAME}-${PV}" 10inherit distutils pypi
16
17inherit distutils