summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-12-11 13:42:02 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-12 12:26:40 -0500
commitaa942604b97da00b045beb7735cba0b975123cca (patch)
tree408b7a11edbd05793901c2b6a203804c78acff3f /recipes-connectivity
parentafbcc5e573bd43145b161cf356e03700bc9eed97 (diff)
downloadmeta-cloud-services-aa942604b97da00b045beb7735cba0b975123cca.tar.gz
hashicorp-serf: add recipe for 0.8.5
Serf is a decentralized solution for service discovery and orchestration that is lightweight, highly available, and fault tolerant. Vendor licenses are included in serf-vendor-licenses.inc, to make the main recipe shorter/easier to read. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/serf/hashicorp-serf_0.8.5.bb32
-rw-r--r--recipes-connectivity/serf/serf-vendor-licenses.inc32
2 files changed, 64 insertions, 0 deletions
diff --git a/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb b/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
new file mode 100644
index 0000000..0b1517b
--- /dev/null
+++ b/recipes-connectivity/serf/hashicorp-serf_0.8.5.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Decentralized Cluster Membership, Failure Detection, and Orchestration."
2DESCRIPTION = "Serf is a decentralized solution for service discovery and \
3orchestration that is lightweight, highly available, and fault tolerant.\
4\
5Serf runs on Linux, Mac OS X, and Windows. An efficient and lightweight gossip \
6protocol is used to communicate with other nodes. Serf can detect node failures \
7and notify the rest of the cluster. An event system is built on top of Serf, \
8letting you use Serf's gossip protocol to propagate events such as deploys, \
9configuration changes, etc. Serf is completely masterless with no single point \
10of failure."
11HOMEPAGE = "https://www.serf.io/"
12SECTION = "network"
13
14LICENSE = "Apache-2.0 & BSD-3-Clause & MIT & MPL-2.0"
15LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=b278a92d2c1509760384428817710378"
16
17require serf-vendor-licenses.inc
18
19GO_IMPORT = "github.com/hashicorp/serf"
20SRC_URI = "git://${GO_IMPORT}.git;protocol=https"
21
22PV = "0.8.5+git${SRCPV}"
23SRCREV = "1d3fdf93bbe5002c5023da50402368a817488691"
24
25S = "${WORKDIR}/git"
26
27inherit go
28
29RDEPENDS_${PN}-dev += "bash make"
30
31# Apache serf in oe-core is a completely different beast
32RCONFLICTS_${PN} = "serf"
diff --git a/recipes-connectivity/serf/serf-vendor-licenses.inc b/recipes-connectivity/serf/serf-vendor-licenses.inc
new file mode 100644
index 0000000..df8665a
--- /dev/null
+++ b/recipes-connectivity/serf/serf-vendor-licenses.inc
@@ -0,0 +1,32 @@
1LIC_FILES_CHKSUM += "\
2 file://src/${GO_IMPORT}/vendor/golang.org/x/crypto/LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707 \
3 file://src/${GO_IMPORT}/vendor/golang.org/x/sys/LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707 \
4 file://src/${GO_IMPORT}/vendor/golang.org/x/net/LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707 \
5 file://src/${GO_IMPORT}/vendor/github.com/google/btree/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
6 file://src/${GO_IMPORT}/vendor/github.com/mitchellh/cli/LICENSE;md5=b278a92d2c1509760384428817710378 \
7 file://src/${GO_IMPORT}/vendor/github.com/mitchellh/mapstructure/LICENSE;md5=3f7765c3d4f58e1f84c4313cecf0f5bd \
8 file://src/${GO_IMPORT}/vendor/github.com/sean-/seed/LICENSE;md5=ae6a5709472e0833798453b9fa793364 \
9 file://src/${GO_IMPORT}/vendor/github.com/ryanuber/columnize/COPYING;md5=4b1989be3dc78e86f2c54cf3b03db7c9 \
10 file://src/${GO_IMPORT}/vendor/github.com/fatih/color/LICENSE.md;md5=316e6d590bdcde7993fb175662c0dd5a \
11 file://src/${GO_IMPORT}/vendor/github.com/posener/complete/LICENSE.txt;md5=6778be8533804ed9e25f746e2f0ba0ee \
12 file://src/${GO_IMPORT}/vendor/github.com/mattn/go-colorable/LICENSE;md5=24ce168f90aec2456a73de1839037245 \
13 file://src/${GO_IMPORT}/vendor/github.com/mattn/go-isatty/LICENSE;md5=f509beadd5a11227c27b5d2ad6c9f2c6 \
14 file://src/${GO_IMPORT}/vendor/github.com/miekg/dns/LICENSE;md5=147353de6868a20caa562d26eab7b3c5 \
15 file://src/${GO_IMPORT}/vendor/github.com/miekg/dns/COPYRIGHT;md5=2ba6b7bd91e16af46a856eca87db2504 \
16 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/golang-lru/LICENSE;md5=f27a50d2e878867827842f2c60e30bfc \
17 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/go-multierror/LICENSE;md5=d44fdeb607e2d2614db9464dbedd4094 \
18 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/go-sockaddr/LICENSE;md5=9741c346eef56131163e13b9db1241b3 \
19 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/errwrap/LICENSE;md5=b278a92d2c1509760384428817710378 \
20 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/go-immutable-radix/LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea \
21 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/go-msgpack/LICENSE;md5=3f4c936a1236aa7f17ca2a0b0ce4bfdd \
22 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/go-syslog/LICENSE;md5=cb04212e101fbbd028f325e04ad45778 \
23 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/mdns/LICENSE;md5=cb04212e101fbbd028f325e04ad45778 \
24 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/go.net/LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707 \
25 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/memberlist/LICENSE;md5=b278a92d2c1509760384428817710378 \
26 file://src/${GO_IMPORT}/vendor/github.com/hashicorp/logutils/LICENSE;md5=b278a92d2c1509760384428817710378 \
27 file://src/${GO_IMPORT}/vendor/github.com/armon/go-metrics/LICENSE;md5=d2d77030c0183e3d1e66d26dc1f243be \
28 file://src/${GO_IMPORT}/vendor/github.com/armon/go-radix/LICENSE;md5=cb04212e101fbbd028f325e04ad45778 \
29 file://src/${GO_IMPORT}/vendor/github.com/armon/circbuf/LICENSE;md5=d2d77030c0183e3d1e66d26dc1f243be \
30 file://src/${GO_IMPORT}/vendor/github.com/bgentry/speakeasy/LICENSE;md5=adf5a740fe07eb2aa1ac54aafe2d41f2 \
31 file://src/${GO_IMPORT}/vendor/github.com/bgentry/speakeasy/LICENSE_WINDOWS;md5=b563ae7163bca24b2c0ed1486f8c944c \
32 "