summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-08-20 15:10:15 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-27 10:08:48 -0400
commit6401ae209fb075981ace2c746f68794a59853cb1 (patch)
tree66c49d0db2ac271705c0289ffc7d93f6b4fff64b /recipes-connectivity
parent61ace10007cd51d8ae4a228a44b4b2d54b45fb1d (diff)
downloadmeta-cloud-services-6401ae209fb075981ace2c746f68794a59853cb1.tar.gz
dhcp: fix double 'request' in dhclient.conf
commit 43e2b093040734d4c4b28db96a634cd2a5f3271b [dhcp: add dhcp classless static route support] had a flaw in one of do_install_append() sed expressions in the dhcp recipe that caused a duplicate 'request' keyword to be inserted in to the dhclient.conf file. The result was that results returned for the request were not as expected and the resolv.conf would be empty. Fixing up the sed expression removes the duplicate and allows things to function properly. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/dhcp/dhcp_4.3.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-connectivity/dhcp/dhcp_4.3.bbappend b/recipes-connectivity/dhcp/dhcp_4.3.bbappend
index f5fb44a..a23f7c9 100644
--- a/recipes-connectivity/dhcp/dhcp_4.3.bbappend
+++ b/recipes-connectivity/dhcp/dhcp_4.3.bbappend
@@ -7,7 +7,7 @@ do_install_append () {
7 install -m 0644 ${WORKDIR}/dhclient-exit-hooks ${D}${sysconfdir}/dhcp/dhclient-exit-hooks 7 install -m 0644 ${WORKDIR}/dhclient-exit-hooks ${D}${sysconfdir}/dhcp/dhclient-exit-hooks
8 sed 's%/etc/dhclient-exit-hooks%/etc/dhcp/dhclient-exit-hooks%g' -i ${D}${base_sbindir}/dhclient-script 8 sed 's%/etc/dhclient-exit-hooks%/etc/dhcp/dhclient-exit-hooks%g' -i ${D}${base_sbindir}/dhclient-script
9 9
10 sed 's%request .*%\noption classless-static-routes code 121 = array of unsigned integer 8;\n\nrequest &%g' -i ${D}${sysconfdir}/dhcp/dhclient.conf 10 sed 's%request .*%\noption classless-static-routes code 121 = array of unsigned integer 8;\n\n&%g' -i ${D}${sysconfdir}/dhcp/dhclient.conf
11 sed 's%netbios-name-servers,.*netbios-scope;%netbios-name-servers, netbios-scope, classless-static-routes;\n%g' -i ${D}${sysconfdir}/dhcp/dhclient.conf 11 sed 's%netbios-name-servers,.*netbios-scope;%netbios-name-servers, netbios-scope, classless-static-routes;\n%g' -i ${D}${sysconfdir}/dhcp/dhclient.conf
12 12
13} 13}