summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2019-03-07 19:28:17 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-03-08 16:01:44 -0500
commit61b2b5b3e38ff63bf39007cb9b7d4773f42a5f85 (patch)
tree6ff08d7b48f3b105416919935a36c6a1ade62b7b /recipes-connectivity
parentf037d515e9551862d5e036ba68be4615fda3b8be (diff)
downloadmeta-cloud-services-61b2b5b3e38ff63bf39007cb9b7d4773f42a5f85.tar.gz
consul: uprev to v1.4.3
Uprev to v1.4.3 and remove invalid patch. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/consul/consul_git.bb5
-rw-r--r--recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch31
2 files changed, 3 insertions, 33 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index b0afa03..f9fb236 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -4,14 +4,15 @@ LICENSE = "MPL-2.0 & BSD & Apache-2.0 & BSD-2-Clause & MIT"
4LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2c1509760384428817710378" 4LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2c1509760384428817710378"
5 5
6GO_IMPORT = "github.com/hashicorp/consul" 6GO_IMPORT = "github.com/hashicorp/consul"
7SRCREV = "f97afda8e15046b41d951bf3b4220372c45df7ab" 7SRCREV = "567e41ff6b096a478333c804d5c18264050bc3f8"
8SRC_URI = "git://${GO_IMPORT}.git \ 8SRC_URI = "git://${GO_IMPORT}.git \
9 file://consul.service \ 9 file://consul.service \
10 file://0001-prepared_query-make-compatible-with-go1.5.patch \
11 " 10 "
12 11
13S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
14 13
14RDEPENDS_${PN}-dev_append = " bash"
15
15inherit systemd go 16inherit systemd go
16 17
17# Besides the hosts specified in goarch, we do not build for mips. 18# Besides the hosts specified in goarch, we do not build for mips.
diff --git a/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch b/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch
deleted file mode 100644
index 324530b..0000000
--- a/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From fb11d9e31788c912f94faf8b188278d54dc9a8f1 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Wed, 20 Apr 2016 16:34:50 -0400
4Subject: [PATCH] prepared_query: make compatible with go1.5
5
6The copying of a regex is only in go 1.6. We can take the chance of
7lock contention, so we drop the copy and use the regex directly.
8
9Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
10---
11 src/github.com/hashicorp/consul/consul/prepared_query/template.go | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/src/github.com/hashicorp/consul/consul/prepared_query/template.go b/src/github.com/hashicorp/consul/consul/prepared_query/template.go
15index 984f0bcf9cc6..1c61910c1526 100644
16--- a/src/github.com/hashicorp/consul/consul/prepared_query/template.go
17+++ b/src/github.com/hashicorp/consul/consul/prepared_query/template.go
18@@ -116,8 +116,8 @@ func (ct *CompiledTemplate) Render(name string) (*structs.PreparedQuery, error)
19 // from multiple goroutines.
20 var matches []string
21 if ct.re != nil {
22- re := ct.re.Copy()
23- matches = re.FindStringSubmatch(name)
24+ // re := ct.re.Copy()
25+ matches = ct.re.FindStringSubmatch(name)
26 }
27
28 // Create a safe match function that can't fail at run time. It will
29--
302.4.0.53.g8440f74
31