summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2019-04-02 21:36:26 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-04-07 23:08:31 -0400
commit394aee1ce7960045787e74e162326835f67ca619 (patch)
treeb0b05c104989cc66d1c8b58fa445bea351e4ba02 /recipes-connectivity
parentae9ff00b3f4f4772ddef33a53ba31abcf4c3b523 (diff)
downloadmeta-cloud-services-394aee1ce7960045787e74e162326835f67ca619.tar.gz
consul: don't build with the '-linkshared' option
We are currently seeing the following error: type..eUfRrckI: missing section for relocation target type..FEeY9FdU ... This is similar to the reported issues http://www.lyddzz.com/github_/golang/go/issues/30768 and https://github.com/hashicorp/consul/issues/5486 (but this one appears to be a report of 'our' issue so isn't really valid) The go.bbclass currently completes 2 builds (if GO_DYNLINK is set), one without '-linkshared' and one with. The '--linkshared' option is marked as experimental (https://golang.org/cmd/link/ -- "-linkshared Link against installed Go shared libraries (experimental)"). By setting GO_LINKSHARED prior to inheriting go.bbclass we can overwrite the default compile behavior and only perform the build without the '-linkshared' option. This shouldn't change the functionality of consul and we can revert to the default behavior when the issues have been addressed. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/consul/consul_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index f9fb236..ab78cbd 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -13,6 +13,11 @@ S = "${WORKDIR}/git"
13 13
14RDEPENDS_${PN}-dev_append = " bash" 14RDEPENDS_${PN}-dev_append = " bash"
15 15
16# Temporarily workaround an issue with GO 1.12.1
17# http://www.lyddzz.com/github_/golang/go/issues/30768
18# Disable experimental use of '-linkshared'.
19GO_LINKSHARED = ""
20
16inherit systemd go 21inherit systemd go
17 22
18# Besides the hosts specified in goarch, we do not build for mips. 23# Besides the hosts specified in goarch, we do not build for mips.