summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorhongxu <hongxu.jia@windriver.com>2019-11-27 22:51:27 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-01 23:08:28 -0500
commit2e00e7d86eab8961711bb9ed77cfe669832378fb (patch)
tree86dc08bdecda85e35296a4a3efb7a79d02daca32 /recipes-connectivity
parent731a56ee1a4a221eae97fa3ea04aa53339a93a14 (diff)
downloadmeta-cloud-services-2e00e7d86eab8961711bb9ed77cfe669832378fb.tar.gz
consul: fix compile failure while go upgraded to 1.13
While go was upgraded to 1.13, there is a do_compile failure, Refer upstream envoyproxy to rename imports throughout https://github.com/envoyproxy/protoc-gen-validate/pull/161/commits/7428b5f8e7fdabbcc7c9710e23e6f438ba4ff021 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/consul/consul_git.bb1
-rw-r--r--recipes-connectivity/consul/files/0001-Migration-Rename-imports-throughout.patch82
2 files changed, 83 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index 566fbc9..b96499c 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2
6GO_IMPORT = "github.com/hashicorp/consul" 6GO_IMPORT = "github.com/hashicorp/consul"
7SRCREV = "944cc71026c007e7de9467ec3f38f0ad14464fcc" 7SRCREV = "944cc71026c007e7de9467ec3f38f0ad14464fcc"
8SRC_URI = "git://${GO_IMPORT}.git \ 8SRC_URI = "git://${GO_IMPORT}.git \
9 file://0001-Migration-Rename-imports-throughout.patch \
9 file://consul.service \ 10 file://consul.service \
10 " 11 "
11 12
diff --git a/recipes-connectivity/consul/files/0001-Migration-Rename-imports-throughout.patch b/recipes-connectivity/consul/files/0001-Migration-Rename-imports-throughout.patch
new file mode 100644
index 0000000..906107d
--- /dev/null
+++ b/recipes-connectivity/consul/files/0001-Migration-Rename-imports-throughout.patch
@@ -0,0 +1,82 @@
1From a9353f184d6cf6ae7ef1b5676720f5bee0882ec3 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 27 Nov 2019 22:38:25 -0800
4Subject: [PATCH] Migration: Rename imports throughout
5
6rename lyft -> envoyproxy
7
8Since upstream envoyproxy update it [https://github.com/envoyproxy/protoc-gen-validate/pull/161/commits/7428b5f8e7fdabbcc7c9710e23e6f438ba4ff021]
9Upstream-Status: Pending
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 .../envoy/api/v2/cluster/circuit_breaker.pb.go | 2 +-
14 .../go-control-plane/envoy/api/v2/route/route.pb.go | 4 ++--
15 .../envoyproxy/protoc-gen-validate/validate/validate.pb.go | 2 +-
16 .../envoyproxy/protoc-gen-validate/validate/validate.proto | 2 +-
17 4 files changed, 5 insertions(+), 5 deletions(-)
18
19diff --git a/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/cluster/circuit_breaker.pb.go b/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/cluster/circuit_breaker.pb.go
20index 30a138eba..7dfcc91e2 100644
21--- a/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/cluster/circuit_breaker.pb.go
22+++ b/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/cluster/circuit_breaker.pb.go
23@@ -87,7 +87,7 @@ type CircuitBreakers_Thresholds struct {
24 // The :ref:`RoutingPriority<envoy_api_enum_core.RoutingPriority>`
25 // the specified CircuitBreaker settings apply to.
26 // [#comment:TODO(htuch): add (validate.rules).enum.defined_only = true once
27- // https://github.com/lyft/protoc-gen-validate/issues/42 is resolved.]
28+ // https://github.com/envoyproxy/protoc-gen-validate/issues/42 is resolved.]
29 Priority core.RoutingPriority `protobuf:"varint,1,opt,name=priority,proto3,enum=envoy.api.v2.core.RoutingPriority" json:"priority,omitempty"`
30 // The maximum number of connections that Envoy will make to the upstream
31 // cluster. If not specified, the default is 1024.
32diff --git a/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/route/route.pb.go b/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/route/route.pb.go
33index cce788c7d..ec69f4769 100644
34--- a/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/route/route.pb.go
35+++ b/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/go-control-plane/envoy/api/v2/route/route.pb.go
36@@ -1513,7 +1513,7 @@ type RouteAction struct {
37 RequestMirrorPolicy *RouteAction_RequestMirrorPolicy `protobuf:"bytes,10,opt,name=request_mirror_policy,json=requestMirrorPolicy,proto3" json:"request_mirror_policy,omitempty"`
38 // Optionally specifies the :ref:`routing priority <arch_overview_http_routing_priority>`.
39 // [#comment:TODO(htuch): add (validate.rules).enum.defined_only = true once
40- // https://github.com/lyft/protoc-gen-validate/issues/42 is resolved.]
41+ // https://github.com/envoyproxy/protoc-gen-validate/issues/42 is resolved.]
42 Priority core.RoutingPriority `protobuf:"varint,11,opt,name=priority,proto3,enum=envoy.api.v2.core.RoutingPriority" json:"priority,omitempty"`
43 // Specifies a set of rate limit configurations that could be applied to the
44 // route.
45@@ -3475,7 +3475,7 @@ type VirtualCluster struct {
46 // Optionally specifies the HTTP method to match on. For example GET, PUT,
47 // etc.
48 // [#comment:TODO(htuch): add (validate.rules).enum.defined_only = true once
49- // https://github.com/lyft/protoc-gen-validate/issues/42 is resolved.]
50+ // https://github.com/envoyproxy/protoc-gen-validate/issues/42 is resolved.]
51 Method core.RequestMethod `protobuf:"varint,3,opt,name=method,proto3,enum=envoy.api.v2.core.RequestMethod" json:"method,omitempty"`
52 XXX_NoUnkeyedLiteral struct{} `json:"-"`
53 XXX_unrecognized []byte `json:"-"`
54diff --git a/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.pb.go b/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.pb.go
55index ef5938c83..9a1a4c08d 100644
56--- a/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.pb.go
57+++ b/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.pb.go
58@@ -1,7 +1,7 @@
59 // Code generated by protoc-gen-go. DO NOT EDIT.
60 // source: validate/validate.proto
61
62-package validate // import "github.com/lyft/protoc-gen-validate/validate"
63+package validate // import "github.com/envoyproxy/protoc-gen-validate/validate"
64
65 import proto "github.com/golang/protobuf/proto"
66 import fmt "fmt"
67diff --git a/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.proto b/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.proto
68index 1c5e04a16..05cce2cbd 100644
69--- a/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.proto
70+++ b/src/github.com/hashicorp/consul/vendor/github.com/envoyproxy/protoc-gen-validate/validate/validate.proto
71@@ -1,7 +1,7 @@
72 syntax = "proto2";
73 package validate;
74
75-option go_package = "github.com/lyft/protoc-gen-validate/validate";
76+option go_package = "github.com/envoyproxy/protoc-gen-validate/validate";
77 option java_package = "com.lyft.pgv.validate";
78
79 import "google/protobuf/descriptor.proto";
80--
812.21.0
82