summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-05-30 12:49:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-04 09:24:46 -0400
commitfc484b6e10fdb39fbcb46c76c06501f27f857da5 (patch)
tree0f4c8e6d0ed99c6e4501785724c660893a4f5531 /meta-openstack
parent5e78faf2cff56de25f6c63fd3c33bd835e4b7d48 (diff)
downloadmeta-cloud-services-fc484b6e10fdb39fbcb46c76c06501f27f857da5.tar.gz
django-nose: add recipe and dependencies for testing
Horizon provides unit tests for testing its deployment in target environment. These tests make use of django-nose testing framework. This provides a recipe for building django-nose and adds a dependency from Horizon on this recipe. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb31
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb2
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb b/meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb
new file mode 100644
index 0000000..0c2eee2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb
@@ -0,0 +1,31 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4DESCRIPTION = "Django test runner using nose"
5HOMEPAGE = "https://github.com/django-nose/django-nose"
6SECTION = "devel/python"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7f88f52f66738ec7259424ce46e855c2"
9
10PR = "r0"
11SRCNAME = "django-nose"
12
13SRC_URI = "http://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
14 "
15
16SRC_URI[md5sum] = "199d5358317a804b39fe05d806cab427"
17SRC_URI[sha256sum] = "9aae16b562866a4ddaa5e8978729abadbbed544728d88e0b9c9af7b31dd072ed"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit setuptools
22
23DEPENDS += " \
24 python-pip \
25 "
26
27RDEPENDS_${PN} += " \
28 python-django \
29 python-nose \
30 "
31
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 9249cc1..f2d4646 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -11,6 +11,7 @@ DEPENDS += " \
11 11
12RDEPENDS_${PN} += "python-django \ 12RDEPENDS_${PN} += "python-django \
13 python-django-compressor \ 13 python-django-compressor \
14 python-django-nose \
14 python-django-openstack-auth \ 15 python-django-openstack-auth \
15 python-netaddr \ 16 python-netaddr \
16 python-cinderclient \ 17 python-cinderclient \
@@ -120,6 +121,7 @@ RDEP_ARCH_VAR_ia32 = "nodejs"
120RDEPENDS_${PN} += " python-django \ 121RDEPENDS_${PN} += " python-django \
121 python-django-appconf \ 122 python-django-appconf \
122 python-django-compressor \ 123 python-django-compressor \
124 python-django-nose \
123 python-django-openstack-auth \ 125 python-django-openstack-auth \
124 python-netaddr \ 126 python-netaddr \
125 python-ceilometerclient \ 127 python-ceilometerclient \