diff options
author | Keith Holman <Keith.Holman@windriver.com> | 2014-05-30 12:49:57 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-06-04 09:24:46 -0400 |
commit | fc484b6e10fdb39fbcb46c76c06501f27f857da5 (patch) | |
tree | 0f4c8e6d0ed99c6e4501785724c660893a4f5531 /meta-openstack | |
parent | 5e78faf2cff56de25f6c63fd3c33bd835e4b7d48 (diff) | |
download | meta-cloud-services-fc484b6e10fdb39fbcb46c76c06501f27f857da5.tar.gz |
django-nose: add recipe and dependencies for testing
Horizon provides unit tests for testing its deployment in
target environment. These tests make use of django-nose
testing framework. This provides a recipe for building
django-nose and adds a dependency from Horizon on this
recipe.
Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb | 31 | ||||
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-horizon_git.bb | 2 |
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb b/meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb new file mode 100644 index 0000000..0c2eee2 --- /dev/null +++ b/meta-openstack/recipes-devtools/python/python-django-nose_1.2.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | # | ||
2 | # Copyright (C) 2014 Wind River Systems, Inc. | ||
3 | # | ||
4 | DESCRIPTION = "Django test runner using nose" | ||
5 | HOMEPAGE = "https://github.com/django-nose/django-nose" | ||
6 | SECTION = "devel/python" | ||
7 | LICENSE = "BSD" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7f88f52f66738ec7259424ce46e855c2" | ||
9 | |||
10 | PR = "r0" | ||
11 | SRCNAME = "django-nose" | ||
12 | |||
13 | SRC_URI = "http://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[md5sum] = "199d5358317a804b39fe05d806cab427" | ||
17 | SRC_URI[sha256sum] = "9aae16b562866a4ddaa5e8978729abadbbed544728d88e0b9c9af7b31dd072ed" | ||
18 | |||
19 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
20 | |||
21 | inherit setuptools | ||
22 | |||
23 | DEPENDS += " \ | ||
24 | python-pip \ | ||
25 | " | ||
26 | |||
27 | RDEPENDS_${PN} += " \ | ||
28 | python-django \ | ||
29 | python-nose \ | ||
30 | " | ||
31 | |||
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb index 9249cc1..f2d4646 100644 --- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb +++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb | |||
@@ -11,6 +11,7 @@ DEPENDS += " \ | |||
11 | 11 | ||
12 | RDEPENDS_${PN} += "python-django \ | 12 | RDEPENDS_${PN} += "python-django \ |
13 | python-django-compressor \ | 13 | python-django-compressor \ |
14 | python-django-nose \ | ||
14 | python-django-openstack-auth \ | 15 | python-django-openstack-auth \ |
15 | python-netaddr \ | 16 | python-netaddr \ |
16 | python-cinderclient \ | 17 | python-cinderclient \ |
@@ -120,6 +121,7 @@ RDEP_ARCH_VAR_ia32 = "nodejs" | |||
120 | RDEPENDS_${PN} += " python-django \ | 121 | RDEPENDS_${PN} += " python-django \ |
121 | python-django-appconf \ | 122 | python-django-appconf \ |
122 | python-django-compressor \ | 123 | python-django-compressor \ |
124 | python-django-nose \ | ||
123 | python-django-openstack-auth \ | 125 | python-django-openstack-auth \ |
124 | python-netaddr \ | 126 | python-netaddr \ |
125 | python-ceilometerclient \ | 127 | python-ceilometerclient \ |