summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorNathan Hartman <hnathan918@gmail.com>2020-02-20 11:58:02 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-27 17:15:41 -0500
commitdfae8c2538bab33e2af4909b98987769a36a8a29 (patch)
treef7bcc3a0fa538524c45c38c1e205f682cd5c5c0e /meta-openstack
parent5ae8e5ed967c41c4f98b4aacc263f24c2526ed3e (diff)
downloadmeta-cloud-services-dfae8c2538bab33e2af4909b98987769a36a8a29.tar.gz
Initial http_parser.rb ruby recipe
Signed-off-by: Nathan Hartman <hnathan918@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
new file mode 100644
index 0000000..db52ebd
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "simple callback-based HTTP request/response parser"
2HOMEPAGE = "https://rubygems.org/gems/http_parser.rb"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=157efc3766c6d07d3d857ebbab43351a"
6
7SRC_URI = "git://github.com/tmm1/http_parser.rb.git;protocol=https;tag=v0.6.0"
8
9S = "${WORKDIR}/git"
10
11# Bitbake doesn't allow the underscore in file name, hence the dash
12SRCNAME = "http_parser.rb"
13
14DEPENDS = "git"
15
16inherit ruby
17
18# Download the submodules
19do_configure_prepend() {
20 cd ${WORKDIR}/git
21 git submodule update --init --recursive
22}