summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-22 11:06:57 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-27 10:39:51 -0500
commitde6773ada3e38be3ce734e9e73288df37de32437 (patch)
tree60c9df6f735b7599b6d5cc8446df2c8477b902d2 /meta-openstack
parentcd6fedc3ba02e275355d60b346d31763fe6e84e8 (diff)
downloadmeta-cloud-services-de6773ada3e38be3ce734e9e73288df37de32437.tar.gz
meta-openstack: initial move to use systemd
Add instructions to the README.setup on how to configure the build to use systemd. The remaining changes are a bit of hack and slash to get the builds to succeed. The 'hacking' only touches core openstack component recipes which are all in various states of broken anyways, so these changes will not affect any current meta-cloud-services users. All of these will be corrected shortly. Most users of OpenStack have long ago made the move to systemd, by following suit we can take advantage of the better support for service files along with matching most OpenStack documentation. The remaining sysvinit parts will be removed as we get the openstack components updated and back to a working state. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/README.setup14
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb12
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb12
-rwxr-xr-xmeta-openstack/recipes-devtools/python/python-trove_git.bb3
8 files changed, 43 insertions, 6 deletions
diff --git a/meta-openstack/README.setup b/meta-openstack/README.setup
index d55883f..b02ebf6 100644
--- a/meta-openstack/README.setup
+++ b/meta-openstack/README.setup
@@ -84,6 +84,20 @@ to the bblayers.conf file:
84 /meta-openembedded/meta-webserver \ 84 /meta-openembedded/meta-webserver \
85 /meta-openembedded/meta-ruby 85 /meta-openembedded/meta-ruby
86 86
87* All images must use systemd init system. After the builddir has been
88initialized you have to append the necessary variables to ensure that
89systemd will be used in your images:
90
91 DISTRO_FEATURES_append = " systemd"
92 DISTRO_FEATURES_BACKFILL_CONSIDERED += "sysvinit"
93 VIRTUAL-RUNTIME_init_manager = "systemd"
94 VIRTUAL-RUNTIME_initscripts = "systemd-compat-units"
95
96Additionally activiate the meta-virtualization layer:
97
98 DISTRO_FEATURES_append += "virtualization kvm"
99
100
87Package configurations 101Package configurations
88---------------------- 102----------------------
89 103
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 9f70beb..3523038 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -152,6 +152,10 @@ pkg_postinst_${SRCNAME}-setup () {
152 152
153PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-volume ${SRCNAME}-scheduler ${SRCNAME}-backup" 153PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-volume ${SRCNAME}-scheduler ${SRCNAME}-backup"
154ALLOW_EMPTY_${SRCNAME}-setup = "1" 154ALLOW_EMPTY_${SRCNAME}-setup = "1"
155ALLOW_EMPTY_${SRCNAME}-backup = "1"
156ALLOW_EMPTY_${SRCNAME}-scheduler = "1"
157ALLOW_EMPTY_${SRCNAME}-volume = "1"
158ALLOW_EMPTY_${SRCNAME}-api = "1"
155 159
156RDEPENDS_${SRCNAME}-tests += " bash python" 160RDEPENDS_${SRCNAME}-tests += " bash python"
157 161
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 4042f1b..4c408c9 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -138,6 +138,8 @@ pkg_postinst_${SRCNAME}-setup () {
138 138
139PACKAGES += " ${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-registry" 139PACKAGES += " ${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-registry"
140ALLOW_EMPTY_${SRCNAME}-setup = "1" 140ALLOW_EMPTY_${SRCNAME}-setup = "1"
141ALLOW_EMPTY_${SRCNAME}-registry = "1"
142ALLOW_EMPTY_${SRCNAME}-api = "1"
141 143
142FILES_${PN} = " \ 144FILES_${PN} = " \
143 ${libdir}/* \ 145 ${libdir}/* \
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 69d19f5..51025e7 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -147,6 +147,7 @@ do_install_append() {
147} 147}
148 148
149PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-apache ${SRCNAME}-standalone" 149PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-apache ${SRCNAME}-standalone"
150ALLOW_EMPTY_${SRCNAME}-standalone = "1"
150 151
151RDEPENDS_${SRCNAME}-tests += " bash" 152RDEPENDS_${SRCNAME}-tests += " bash"
152 153
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index a26c9bf..b5f92dd 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -128,12 +128,12 @@ do_install_append() {
128 sed -e "s:%TOKEN_FORMAT%:${TOKEN_FORMAT}:g" \ 128 sed -e "s:%TOKEN_FORMAT%:${TOKEN_FORMAT}:g" \
129 -i ${KEYSTONE_CONF_DIR}/keystone.conf 129 -i ${KEYSTONE_CONF_DIR}/keystone.conf
130 130
131 sed -e "s/%ADMIN_PASSWORD%/${ADMIN_PASSWORD}/g" \ 131# sed -e "s/%ADMIN_PASSWORD%/${ADMIN_PASSWORD}/g" \
132 -i ${D}${sysconfdir}/init.d/keystone 132# -i ${D}${sysconfdir}/init.d/keystone
133 sed -e "s/%SERVICE_PASSWORD%/${SERVICE_PASSWORD}/g" \ 133# sed -e "s/%SERVICE_PASSWORD%/${SERVICE_PASSWORD}/g" \
134 -i ${D}${sysconfdir}/init.d/keystone 134# -i ${D}${sysconfdir}/init.d/keystone
135 sed -e "s/%SERVICE_TENANT_NAME%/${SERVICE_TENANT_NAME}/g" \ 135# sed -e "s/%SERVICE_TENANT_NAME%/${SERVICE_TENANT_NAME}/g" \
136 -i ${D}${sysconfdir}/init.d/keystone 136# -i ${D}${sysconfdir}/init.d/keystone
137 137
138 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp 138 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp
139 139
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index c837401..f2a4baa 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -56,6 +56,7 @@ do_install_append() {
56 install -m 600 ${S}/etc/api-paste.ini ${NEUTRON_CONF_DIR}/ 56 install -m 600 ${S}/etc/api-paste.ini ${NEUTRON_CONF_DIR}/
57 install -m 600 ${S}/etc/policy.json ${NEUTRON_CONF_DIR}/ 57 install -m 600 ${S}/etc/policy.json ${NEUTRON_CONF_DIR}/
58 install -m 600 ${TEMPLATE_CONF_DIR}/neutron/plugins/ml2/* ${NEUTRON_CONF_DIR}/plugins/ml2 58 install -m 600 ${TEMPLATE_CONF_DIR}/neutron/plugins/ml2/* ${NEUTRON_CONF_DIR}/plugins/ml2
59 install -m 600 ${WORKDIR}/metadata_agent.ini ${NEUTRON_CONF_DIR}/
59 60
60 # Neutron.conf config changes (replace with .ini file editing) 61 # Neutron.conf config changes (replace with .ini file editing)
61 sed -e "s:^# core_plugin.*:core_plugin = ml2:g" -i ${NEUTRON_CONF_DIR}/neutron.conf 62 sed -e "s:^# core_plugin.*:core_plugin = ml2:g" -i ${NEUTRON_CONF_DIR}/neutron.conf
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index 7b560a7..115d198 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -212,6 +212,18 @@ FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
212 212
213ALLOW_EMPTY_${SRCNAME}-setup = "1" 213ALLOW_EMPTY_${SRCNAME}-setup = "1"
214ALLOW_EMPTY_${SRCNAME}-ec2 = "1" 214ALLOW_EMPTY_${SRCNAME}-ec2 = "1"
215ALLOW_EMPTY_${SRCNAME}-api = "1"
216ALLOW_EMPTY_${SRCNAME}-compute = "1"
217ALLOW_EMPTY_${SRCNAME}-controller = "1"
218ALLOW_EMPTY_${SRCNAME}-consoleauth = "1"
219ALLOW_EMPTY_${SRCNAME}-cert = "1"
220ALLOW_EMPTY_${SRCNAME}-conductor = "1"
221ALLOW_EMPTY_${SRCNAME}-network = "1"
222ALLOW_EMPTY_${SRCNAME}-novncproxy = "1"
223ALLOW_EMPTY_${SRCNAME}-scheduler = "1"
224ALLOW_EMPTY_${SRCNAME}-spicehtml5proxy = "1"
225
226
215 227
216FILES_${PN} = "${libdir}/*" 228FILES_${PN} = "${libdir}/*"
217 229
diff --git a/meta-openstack/recipes-devtools/python/python-trove_git.bb b/meta-openstack/recipes-devtools/python/python-trove_git.bb
index b90e552..e1f8ae0 100755
--- a/meta-openstack/recipes-devtools/python/python-trove_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-trove_git.bb
@@ -210,6 +210,7 @@ FILES_${SRCNAME} = " \
210FILES_${SRCNAME}-api = " \ 210FILES_${SRCNAME}-api = " \
211 ${sysconfdir}/init.d/trove-api \ 211 ${sysconfdir}/init.d/trove-api \
212 " 212 "
213ALLOW_EMPTY_${SRCNAME}-api = "1"
213 214
214FILES_${SRCNAME}-bin = " \ 215FILES_${SRCNAME}-bin = " \
215 ${bindir}/* \ 216 ${bindir}/* \
@@ -218,10 +219,12 @@ FILES_${SRCNAME}-bin = " \
218FILES_${SRCNAME}-conductor = " \ 219FILES_${SRCNAME}-conductor = " \
219 ${sysconfdir}/init.d/trove-conductor \ 220 ${sysconfdir}/init.d/trove-conductor \
220 " 221 "
222ALLOW_EMPTY_${SRCNAME}-conductor = "1"
221 223
222FILES_${SRCNAME}-taskmanager = " \ 224FILES_${SRCNAME}-taskmanager = " \
223 ${sysconfdir}/init.d/trove-taskmanager \ 225 ${sysconfdir}/init.d/trove-taskmanager \
224 " 226 "
227ALLOW_EMPTY_${SRCNAME}-taskmanager = "1"
225 228
226FILES_${SRCNAME}-setup = " \ 229FILES_${SRCNAME}-setup = " \
227 ${localstatedir}/* \ 230 ${localstatedir}/* \