summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-07-28 09:35:20 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-30 15:48:00 -0400
commitd9123a0f2f8de17b7d5776c1e4e5b49246ae6291 (patch)
tree1beebffa768c1fe0b96464660a42dd4c0699662a /meta-openstack
parentaa68b4528c933f9ef107017494fc9368c6476e87 (diff)
downloadmeta-cloud-services-d9123a0f2f8de17b7d5776c1e4e5b49246ae6291.tar.gz
python3-unicodecsv: Change to python3
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>/ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-unicodecsv_0.14.1.bb18
2 files changed, 18 insertions, 24 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb b/meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb
deleted file mode 100644
index 548543e..0000000
--- a/meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "Python2's stdlib csv module replacement with unicode support"
2HOMEPAGE = "https://github.com/jdunck/python-unicodecsv"
3SECTION = "devel/python"
4LICENSE = "BSD"
5
6PV = "0.14.1+git${SRCPV}"
7SRCREV = "4563e33ce322f5e2dea41e76cb33dc0e008ad341"
8
9SRCNAME = "unicodecsv"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=e71cdeaa2d2d59b225b8dfb9363fa590"
12SRC_URI = "git://github.com/jdunck/${BPN}.git"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18DEPENDS += " \
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 "
24
diff --git a/meta-openstack/recipes-devtools/python/python3-unicodecsv_0.14.1.bb b/meta-openstack/recipes-devtools/python/python3-unicodecsv_0.14.1.bb
new file mode 100644
index 0000000..ca8c069
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-unicodecsv_0.14.1.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Python2's stdlib csv module replacement with unicode support"
2HOMEPAGE = "https://github.com/jdunck/python-unicodecsv"
3SECTION = "devel/python"
4LICENSE = "BSD"
5
6LIC_FILES_CHKSUM = "file://PKG-INFO;md5=776dee90d219355b4ffd5c06fda5a39d"
7
8SRC_URI[sha256sum] = "018c08037d48649a0412063ff4eda26eaa81eff1546dbffa51fa5293276ff7fc"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-pbr \
14 "
15
16RDEPENDS_${PN} += " \
17 "
18