summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-09-02 19:52:16 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-03 15:51:04 -0400
commitc288dd6150a2437366de6d234b00b45ed6011dec (patch)
tree75e677fbc14f45d8f0c3c8ddbbf2d487b835a124 /meta-openstack
parent854e461d17bd665e5fbecc0ad0753be58440de40 (diff)
downloadmeta-cloud-services-c288dd6150a2437366de6d234b00b45ed6011dec.tar.gz
python-rfc3986: Add python3 version
Providing a python3 version of python-rfc3986. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-rfc3986.inc20
-rw-r--r--meta-openstack/recipes-devtools/python/python-rfc3986_1.3.2.bb22
-rw-r--r--meta-openstack/recipes-devtools/python/python3-rfc3986_1.3.2.bb2
3 files changed, 24 insertions, 20 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-rfc3986.inc b/meta-openstack/recipes-devtools/python/python-rfc3986.inc
new file mode 100644
index 0000000..d930fd9
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-rfc3986.inc
@@ -0,0 +1,20 @@
1DESCRIPTION = "Validating URI References per RFC 3986"
2HOMEPAGE = "https://rfc3986.rtfd.org"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=03731a0e7dbcb30cecdcec77cc93ec29"
6
7SRC_URI[md5sum] = "5b6d009806a94d418c82d48219a256de"
8SRC_URI[sha256sum] = "0344d0bd428126ce554e7ca2b61787b6a28d2bbd19fc70ed2dd85efe31176405"
9
10inherit pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 "
diff --git a/meta-openstack/recipes-devtools/python/python-rfc3986_1.3.2.bb b/meta-openstack/recipes-devtools/python/python-rfc3986_1.3.2.bb
index e32f903..003f6e1 100644
--- a/meta-openstack/recipes-devtools/python/python-rfc3986_1.3.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-rfc3986_1.3.2.bb
@@ -1,20 +1,2 @@
1DESCRIPTION = "Validating URI References per RFC 3986" 1inherit setuptools
2HOMEPAGE = "https://rfc3986.rtfd.org" 2require python-rfc3986.inc
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=03731a0e7dbcb30cecdcec77cc93ec29"
6
7SRC_URI[md5sum] = "5b6d009806a94d418c82d48219a256de"
8SRC_URI[sha256sum] = "0344d0bd428126ce554e7ca2b61787b6a28d2bbd19fc70ed2dd85efe31176405"
9
10inherit setuptools pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 python-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 "
diff --git a/meta-openstack/recipes-devtools/python/python3-rfc3986_1.3.2.bb b/meta-openstack/recipes-devtools/python/python3-rfc3986_1.3.2.bb
new file mode 100644
index 0000000..5e91d48
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-rfc3986_1.3.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-rfc3986.inc