summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:14 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitaee7381269b29cf8508f6708fb9985ed9cf95814 (patch)
tree8ec68e0fc5492d43fb5e038a6f8770545ddf8c07 /meta-openstack
parent67f308f82a6fd75a8743e681a143330308a0267f (diff)
downloadmeta-cloud-services-aee7381269b29cf8508f6708fb9985ed9cf95814.tar.gz
python-contextlib2: initial version
This package provides backports and enhancements for the contextlib module. This package is required by futurist and taskflow. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-contextlib2_0.4.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-contextlib2_0.4.0.bb b/meta-openstack/recipes-devtools/python/python-contextlib2_0.4.0.bb
new file mode 100644
index 0000000..2bede47
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-contextlib2_0.4.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Backports and enhancements for the contextlib module"
2HOMEPAGE = "http://contextlib2.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=43d1c7827e8fad6454b553caf0e1d734"
6
7SRCNAME = "contextlib2"
8
9SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "ea687207db25f65552061db4a2c6727d"
12SRC_URI[sha256sum] = "55a5dc78f7a742a0e756645134ffb39bbe11da0fea2bc0f7070d40dac208b732"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18DEPENDS += " \
19 python-pip \
20 "
21
22RDEPENDS_${PN} += " \
23 "
24