summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-07-20 22:36:55 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-20 14:50:13 -0400
commitae7239c9f5373a3fe584db5d0414267bc9d7f776 (patch)
tree2938edb74b15322c6a17a20c45d1a46a532cced7 /meta-openstack
parent8ca48ab23da204761034ed1b02949bcb25f4a2fb (diff)
downloadmeta-cloud-services-ae7239c9f5373a3fe584db5d0414267bc9d7f776.tar.gz
python3-designateclient: Change to python3
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-designateclient_git.bb37
-rw-r--r--meta-openstack/recipes-devtools/python/python3-designateclient_4.0.0.bb34
2 files changed, 34 insertions, 37 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-designateclient_git.bb b/meta-openstack/recipes-devtools/python/python-designateclient_git.bb
deleted file mode 100644
index fdc92c2..0000000
--- a/meta-openstack/recipes-devtools/python/python-designateclient_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "Python bindings to the Designate API"
2HOMEPAGE = "https://github.com/openstack/python-designateclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15 "
16
17RDEPENDS_${PN} += " \
18 python-cliff \
19 python-jsonschema \
20 python-osc-lib \
21 python-oslo.utils \
22 python-pbr \
23 python-keystoneauth1 \
24 python-requests \
25 python-six \
26 python-stevedore \
27 python-debtcollector \
28 "
29
30SRCNAME = "designateclient"
31SRC_URI = "git://github.com/openstack/${BPN}.git;branch=master"
32
33PV = "3.0.0+git${SRCPV}"
34SRCREV = "093d8d7170cbf6ef8c7a7c0ff2a4dcd7ecd6361b"
35S = "${WORKDIR}/git"
36
37inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-designateclient_4.0.0.bb b/meta-openstack/recipes-devtools/python/python3-designateclient_4.0.0.bb
new file mode 100644
index 0000000..891f048
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-designateclient_4.0.0.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Python bindings to the Designate API"
2HOMEPAGE = "https://github.com/openstack/python-designateclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 python3-pip \
9 python3-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python3-pbr-native \
15 "
16SRC_URI[md5sum] = "ad4ca221c5209261cf0eaf2824b07b55"
17SRC_URI[sha256sum] = "d61e7999f0cbb55d2b6e7dec7a6232389d3034de27c1e80b7d5c69d60dd58dbf"
18
19RDEPENDS_${PN} += " \
20 python3-cliff \
21 python3-jsonschema \
22 python3-osc-lib \
23 python3-oslo.utils \
24 python3-pbr \
25 python3-keystoneauth1 \
26 python3-requests \
27 python3-six \
28 python3-stevedore \
29 python3-debtcollector \
30 "
31
32PYPI_PACKAGE = "python-designateclient"
33
34inherit setuptools3 pypi