summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-11-29 09:35:06 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-01 23:17:09 -0500
commit78afdd242899e6287e05f48e4e43e80a899e6733 (patch)
treece1432098c5af5ca360a220f864614425d8d79bd /meta-openstack
parentec16a992e6589fc5ddcd80510120f0d960794f65 (diff)
downloadmeta-cloud-services-78afdd242899e6287e05f48e4e43e80a899e6733.tar.gz
python-beautifulsoup4: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-beautifulsoup4.inc16
-rw-r--r--meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.1.bb18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-beautifulsoup4_4.4.1.bb2
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-beautifulsoup4.inc b/meta-openstack/recipes-devtools/python/python-beautifulsoup4.inc
new file mode 100644
index 0000000..4ff500b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-beautifulsoup4.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "Screen-scraping library"
2HOMEPAGE = "https://pypi.python.org/pypi/beautifulsoup4/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=39dacabe5494f61c8680f6fa7323b596"
6
7SRC_URI[md5sum] = "8fbd9a7cac0704645fa20d1419036815"
8SRC_URI[sha256sum] = "87d4013d0625d4789a4f56b8d79a04d5ce6db1152bb65f1d39744f7709a366b4"
9
10inherit pypi
11
12# avoid "error: option --single-version-externally-managed not recognized"
13DISTUTILS_INSTALL_ARGS = "--root=${D} \
14 --prefix=${prefix} \
15 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
16 --install-data=${datadir}"
diff --git a/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.1.bb b/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.1.bb
index cb72f87..595fe5f 100644
--- a/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.1.bb
@@ -1,16 +1,2 @@
1DESCRIPTION = "Screen-scraping library" 1require python-beautifulsoup4.inc
2HOMEPAGE = "https://pypi.python.org/pypi/beautifulsoup4/" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=39dacabe5494f61c8680f6fa7323b596"
6
7SRC_URI[md5sum] = "8fbd9a7cac0704645fa20d1419036815"
8SRC_URI[sha256sum] = "87d4013d0625d4789a4f56b8d79a04d5ce6db1152bb65f1d39744f7709a366b4"
9
10inherit setuptools pypi
11
12# avoid "error: option --single-version-externally-managed not recognized"
13DISTUTILS_INSTALL_ARGS = "--root=${D} \
14 --prefix=${prefix} \
15 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
16 --install-data=${datadir}"
diff --git a/meta-openstack/recipes-devtools/python/python3-beautifulsoup4_4.4.1.bb b/meta-openstack/recipes-devtools/python/python3-beautifulsoup4_4.4.1.bb
new file mode 100644
index 0000000..3bc9066
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-beautifulsoup4_4.4.1.bb
@@ -0,0 +1,2 @@
1require python-beautifulsoup4.inc
2inherit setuptools3