summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-02 09:33:30 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-03 01:16:39 -0400
commit45c125cd53f69a9ced0ed2841d86977a8bfdb88f (patch)
treea234b6c34fefa5ac84e53d3148ac7681696a4aa0 /meta-openstack
parente453b41853be01dad8c2f672b3dbb50833e7d2a1 (diff)
downloadmeta-cloud-services-45c125cd53f69a9ced0ed2841d86977a8bfdb88f.tar.gz
openstack: extra space, network facilities to controller image and deployment
Various components (such as rabbitmq) have checks for minimum amounts of free space on a image. If those checks fail, the service exits in a hard to debug manner. To ensure that these services run, and meet typical usage scenarios, we increase the free space in the image to 3G. We also automatically include the network node packages into this image type, to ensure that full quantum functionality is available. Finally, we inherit openstack-image-base, to trigger simple rootfs configuration and deployment. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-controller.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-openstack/recipes-extended/images/openstack-image-controller.bb b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
index b4bba86..a57b54b 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-controller.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
@@ -6,11 +6,14 @@ IMAGE_INSTALL = "\
6 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \ 6 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
7 packagegroup-core-basic \ 7 packagegroup-core-basic \
8 packagegroup-cloud-controller \ 8 packagegroup-cloud-controller \
9 packagegroup-cloud-network \
9 " 10 "
10 11
11IMAGE_FEATURES += " ssh-server-openssh" 12IMAGE_FEATURES += " ssh-server-openssh"
12 13
13inherit core-image 14inherit core-image
15inherit openstack-base
14 16
15# Ensure extra space for guest images 17# Ensure extra space for guest images, and rabbit MQ has a hard coded
16IMAGE_ROOTFS_EXTRA_SPACE = "2000000" 18# check for 2G of free space, so we use 3G as a starting point.
19IMAGE_ROOTFS_EXTRA_SPACE = "3000000"