summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-12-04 11:58:52 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-06 14:10:46 -0500
commit322105212b91c73b295fd7fda7196cb57e93e85b (patch)
tree5c9ced696714ae57b246f7187d1ada5dd27e0376 /meta-openstack
parentdf9c12fe33a6eb9b3f05b344635a093b7bc1d9df (diff)
downloadmeta-cloud-services-322105212b91c73b295fd7fda7196cb57e93e85b.tar.gz
python-mccabe: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-mccabe.inc14
-rw-r--r--meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb16
-rw-r--r--meta-openstack/recipes-devtools/python/python3-mccabe_0.2.1.bb2
3 files changed, 18 insertions, 14 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-mccabe.inc b/meta-openstack/recipes-devtools/python/python-mccabe.inc
new file mode 100644
index 0000000..5f5e91d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-mccabe.inc
@@ -0,0 +1,14 @@
1DESCRIPTION = "McCabe checker, plugin for flake8"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README.rst;md5=aa0383f6aee4f5c20084a97cd13164c4"
6
7SRC_URI[md5sum] = "5a3f3fa6a4bad126c88aaaa7dab682f5"
8SRC_URI[sha256sum] = "5a2a170e47de5593a6abfae1e9542bd2c3924ac62bbe4e6ed96c953c0352243a"
9
10inherit pypi
11
12RDEPENDS_${PN} += "${PYTHON_PN}-prettytable \
13 ${PYTHON_PN}-cmd2 \
14 ${PYTHON_PN}-pyparsing"
diff --git a/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb b/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb
index fac44d9..68c2238 100644
--- a/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-mccabe_0.2.1.bb
@@ -1,14 +1,2 @@
1DESCRIPTION = "McCabe checker, plugin for flake8" 1require python-mccabe.inc
2HOMEPAGE = "https://github.com/dreamhost/cliff" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README.rst;md5=aa0383f6aee4f5c20084a97cd13164c4"
6
7SRC_URI[md5sum] = "5a3f3fa6a4bad126c88aaaa7dab682f5"
8SRC_URI[sha256sum] = "5a2a170e47de5593a6abfae1e9542bd2c3924ac62bbe4e6ed96c953c0352243a"
9
10inherit setuptools pypi
11
12RDEPENDS_${PN} += "python-prettytable \
13 python-cmd2 \
14 python-pyparsing" \ No newline at end of file
diff --git a/meta-openstack/recipes-devtools/python/python3-mccabe_0.2.1.bb b/meta-openstack/recipes-devtools/python/python3-mccabe_0.2.1.bb
new file mode 100644
index 0000000..8af8ec5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-mccabe_0.2.1.bb
@@ -0,0 +1,2 @@
1require python-mccabe.inc
2inherit setuptools3