summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-08-10 00:45:09 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:59 -0400
commit2eab461d950a7a8e06c0f66d69ed8ca989ece0d8 (patch)
treed1cf791244b09677ee5ff2e6e323016fd4128c79 /meta-openstack
parentf8bd276f5bd89d9d4ae5f44e6515c04b78590a5d (diff)
downloadmeta-cloud-services-2eab461d950a7a8e06c0f66d69ed8ca989ece0d8.tar.gz
python-setuptools: avoid conflicting site.py
Several python recipes install a site.py file. To avoid package install problems with the conflicting file, we remove site.py from this package. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-setuptools-git_1.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-setuptools-git_1.0.bb b/meta-openstack/recipes-devtools/python/python-setuptools-git_1.0.bb
index f03645c..8c41969 100644
--- a/meta-openstack/recipes-devtools/python/python-setuptools-git_1.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-setuptools-git_1.0.bb
@@ -16,3 +16,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}b1"
16 16
17inherit setuptools 17inherit setuptools
18 18
19# conflicting file prevention
20do_install_append() {
21 rm -f ${D}${libdir}/python*/site-packages/site.py*
22}