summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 00:44:28 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:35 -0500
commit2366317a61248a09c7261adac6a6abfe15ef4ca1 (patch)
tree377b4835ddd7ad6b451d701776513a9efb40eea0 /meta-openstack
parent38c09e8209d510b5cf4261727de00a05946e090f (diff)
downloadmeta-cloud-services-2366317a61248a09c7261adac6a6abfe15ef4ca1.tar.gz
python-lesscpy: python LESS compiler
To provide compression and template capabilities the havana release of horizon requires lesscpy. But lesscpy is typically a python3 acript, so not only do we introduce the recipe, we make it compatible with python2. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-lesscpy/0001-lesscpy-remove-explicit-python3.patch23
-rw-r--r--meta-openstack/recipes-devtools/python/python-lesscpy/0002-Description-Fixup-for-python3.3-compat.patch31
-rw-r--r--meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb28
3 files changed, 82 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-lesscpy/0001-lesscpy-remove-explicit-python3.patch b/meta-openstack/recipes-devtools/python/python-lesscpy/0001-lesscpy-remove-explicit-python3.patch
new file mode 100644
index 0000000..36dc7dc
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-lesscpy/0001-lesscpy-remove-explicit-python3.patch
@@ -0,0 +1,23 @@
1From 3331202e96593d47b8e3a253777ea94537fc08f2 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Wed, 30 Oct 2013 23:09:56 -0400
4Subject: [PATCH 1/2] lesscpy: remove explicit python3
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
7---
8 bin/lesscpy | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/bin/lesscpy b/bin/lesscpy
12index 4613f9e..0834996 100755
13--- a/bin/lesscpy
14+++ b/bin/lesscpy
15@@ -1,4 +1,4 @@
16-#!/usr/bin/env python3
17+#!/usr/bin/env python
18 """
19 Lesscpy run script
20 <jtm@robot.is>
21--
221.7.10.4
23
diff --git a/meta-openstack/recipes-devtools/python/python-lesscpy/0002-Description-Fixup-for-python3.3-compat.patch b/meta-openstack/recipes-devtools/python/python-lesscpy/0002-Description-Fixup-for-python3.3-compat.patch
new file mode 100644
index 0000000..b5da15a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-lesscpy/0002-Description-Fixup-for-python3.3-compat.patch
@@ -0,0 +1,31 @@
1From 8b9fb203948ca752d848cee951ccde2954abcfe3 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Wed, 30 Oct 2013 23:17:28 -0400
4Subject: [PATCH 2/2] Description: Fixup for python3.3 compat Author: James
5 Page <james.page@ubuntu.com> Forwarded:
6 https://github.com/robotis/Lesscpy/pull/23
7
8Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
9---
10 lesscpy/scripts/compiler.py | 5 +++--
11 1 file changed, 3 insertions(+), 2 deletions(-)
12
13diff --git a/lesscpy/scripts/compiler.py b/lesscpy/scripts/compiler.py
14index f6b92c7..93dabd3 100644
15--- a/lesscpy/scripts/compiler.py
16+++ b/lesscpy/scripts/compiler.py
17@@ -84,8 +84,9 @@ def run():
18 """Run compiler
19 """
20 aparse = argparse.ArgumentParser(description='LessCss Compiler',
21- epilog='<< jtm@robot.is @_o >>',
22- version=VERSION_STR)
23+ epilog='<< jtm@robot.is @_o >>')
24+ aparse.add_argument('-v', '--version', action='version',
25+ version=VERSION_STR)
26 aparse.add_argument('-I', '--include', action="store", type=str,
27 help="Included less-files (comma separated)")
28 aparse.add_argument('-V', '--verbose', action="store_true",
29--
301.7.10.4
31
diff --git a/meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb b/meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb
new file mode 100644
index 0000000..3bee660
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Python lesscpy: Python LESS Compiler"
2HOMEPAGE = "https://pypi.python.org/pypi/lesscpy"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a01aae31681ac25b4c46f98d627b9b5d"
6
7PR = "r0"
8SRCNAME = "lesscpy"
9
10SRC_URI = "https://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-lesscpy-remove-explicit-python3.patch \
12 file://0002-Description-Fixup-for-python3.3-compat.patch \
13 "
14
15DEPENDS += "python-ply"
16RDEPENDS_${PN} += "python-ply"
17
18SRC_URI[md5sum] = "a9587da0148463d6521f386294c9d6f3"
19SRC_URI[sha256sum] = "fa01d435a1ab3abafba683519bdc7aca5e19399e96225e1a8bc1d660b566364d"
20
21S = "${WORKDIR}/${SRCNAME}-${PV}"
22
23inherit distutils
24
25DISTUTILS_INSTALL_ARGS = "--root=${D} \
26 --prefix=${prefix} \
27 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
28 --install-data=${datadir}"