summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-12-11 11:59:36 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-12 12:28:32 -0500
commit1b7fd012a51f85bef0d655e1bab268f1086ad503 (patch)
tree36023be681bf10300125e8b1b14a5b8c182db8e0 /meta-openstack
parent37a909e8be9f75b09cb00a44f86550354711ce66 (diff)
downloadmeta-cloud-services-1b7fd012a51f85bef0d655e1bab268f1086ad503.tar.gz
python-monotonic: Remove the recipe
Because there are higher versions and python3 versions in meta-openembedded, Remove the recipe. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-monotonic_git.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-monotonic_git.bb b/meta-openstack/recipes-devtools/python/python-monotonic_git.bb
deleted file mode 100644
index 2552409..0000000
--- a/meta-openstack/recipes-devtools/python/python-monotonic_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1DESCRIPTION = "An implementation of time.monotonic()"
2HOMEPAGE = "https://github.com/atdt/monotonic"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7PV = "0.4"
8SRCREV = "93b3d3ba63597e57b20333db4e33ca0f48debf2a"
9
10SRCNAME = "monotonic"
11SRC_URI = "git://github.com/atdt/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit distutils
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 "
24
25do_install_append() {
26 # Using these "longest" paths will ensure needed shorter paths will be created
27 install -d ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info
28
29 install -m 644 ${S}/${SRCNAME}.py ${D}/${libdir}/python2.7/site-packages/
30 install -m 644 ${S}/${SRCNAME}.egg-info/* ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info/
31}