summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-07-28 08:44:55 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-30 15:45:58 -0400
commit13fff861efce1e32bc19a375d81b2e36d9d394c4 (patch)
tree21e5ec5441be0be55ca71611c049c7d0de27d267 /meta-openstack
parentddfe1ab29a36032213eddeaa808aa1f05775a756 (diff)
downloadmeta-cloud-services-13fff861efce1e32bc19a375d81b2e36d9d394c4.tar.gz
python3-keystoneclient: Change python to python3
Version updated to 3.13.1 Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keystoneclient/keystone-api-check.sh (renamed from meta-openstack/recipes-devtools/python/python-keystoneclient/keystone-api-check.sh)0
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keystoneclient_git.bb (renamed from meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb)40
2 files changed, 21 insertions, 19 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient/keystone-api-check.sh b/meta-openstack/recipes-devtools/python/python3-keystoneclient/keystone-api-check.sh
index aba6d5f..aba6d5f 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient/keystone-api-check.sh
+++ b/meta-openstack/recipes-devtools/python/python3-keystoneclient/keystone-api-check.sh
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python3-keystoneclient_git.bb
index c7bfef4..c8fe38a 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-keystoneclient_git.bb
@@ -6,12 +6,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
6 6
7SRCNAME = "keystoneclient" 7SRCNAME = "keystoneclient"
8 8
9SRC_URI = "file://keystone-api-check.sh"
10
9SRC_URI = "\ 11SRC_URI = "\
10 git://github.com/openstack/python-keystoneclient.git;branch=stable/pike \ 12 git://github.com/openstack/python-keystoneclient.git;branch=stable/pike \
11 file://keystone-api-check.sh \ 13 file://keystone-api-check.sh \
12 " 14 "
13 15
14PV = "3.13.0+git${SRCPV}" 16PV = "4.1.0+git${SRCPV}"
15SRCREV = "7ff05baa1fa56f152173651f16fc6fd181291292" 17SRCREV = "7ff05baa1fa56f152173651f16fc6fd181291292"
16S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
17 19
@@ -20,28 +22,28 @@ inherit setuptools3 monitor
20FILES_${PN}-doc += "${datadir}/keystoneclient" 22FILES_${PN}-doc += "${datadir}/keystoneclient"
21 23
22DEPENDS += " \ 24DEPENDS += " \
23 python-pip \ 25 python3-pip \
24 python-pbr \ 26 python3-pbr \
25 " 27 "
26 28
27# Satisfy setup.py 'setup_requires' 29# Satisfy setup.py 'setup_requires'
28DEPENDS += " \ 30DEPENDS += " \
29 python-pbr-native \ 31 python3-pbr-native \
30 " 32 "
31 33
32RDEPENDS_${PN} += " \ 34RDEPENDS_${PN} += " \
33 bash \ 35 bash \
34 python-pbr \ 36 python3-pbr \
35 python-debtcollector \ 37 python3-debtcollector \
36 python-keystoneauth1 \ 38 python3-keystoneauth1 \
37 python-oslo.config \ 39 python3-oslo.config \
38 python-oslo.i18n \ 40 python3-oslo.i18n \
39 python-oslo.serialization \ 41 python3-oslo.serialization \
40 python-oslo.utils \ 42 python3-oslo.utils \
41 python-positional \ 43 python3-positional \
42 python-requests \ 44 python3-requests \
43 python-six \ 45 python3-six \
44 python-stevedore \ 46 python3-stevedore \
45 " 47 "
46 48
47do_install_append() { 49do_install_append() {
@@ -53,7 +55,7 @@ PACKAGES =+ " ${SRCNAME}-tests"
53FILES_${SRCNAME}-tests = "${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \ 55FILES_${SRCNAME}-tests = "${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \
54 " 56 "
55RDEPENDS_${SRCNAME}-tests += " \ 57RDEPENDS_${SRCNAME}-tests += " \
56 python-httpretty \ 58 python3-httpretty \
57 bash \ 59 bash \
58 " 60 "
59 61