summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-12-11 09:47:31 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-12 12:28:32 -0500
commit08db85f22e226cf1c3a038e97df3f047b3a6f376 (patch)
tree3a026485f5068063f3aa64bbda4f1339605b6353 /meta-openstack
parent3496a76f0e8a364168ad6450f2f1d040af9ed654 (diff)
downloadmeta-cloud-services-08db85f22e226cf1c3a038e97df3f047b3a6f376.tar.gz
python-appdirs: Remove the recipe
Because there are higher versions and python3 versions in meta-openembedded, Remove the recipe. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-appdirs_git.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-appdirs_git.bb b/meta-openstack/recipes-devtools/python/python-appdirs_git.bb
deleted file mode 100644
index 2482871..0000000
--- a/meta-openstack/recipes-devtools/python/python-appdirs_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1DESCRIPTION = "A small Python module for determining appropriate platform-specific dirs, e.g. a user data dir."
2HOMEPAGE = "http://github.com/ActiveState/appdirs"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=31625363c45eb0c67c630a2f73e438e4"
6
7PV = "1.4.0"
8SRCREV = "57f2bc44a8bca99bac6c57496c8b3fdea26f94d5"
9
10SRCNAME = "appdirs"
11SRC_URI = "git://github.com/ActiveState/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pip \
23 "
24
25do_install_append() {
26 # Using these "longest" paths will ensure needed shorter paths will be created
27 install -d ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/test
28 install -d ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info
29
30 install -m 644 ${S}/${SRCNAME}.py ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/__init__.py
31 install -m 644 ${S}/${SRCNAME}.pyc ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/__init__.pyc
32 install -m 644 ${S}/test/* ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/test/
33 install -m 644 ${S}/${SRCNAME}.egg-info/* ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info/
34}