summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-07-18 15:51:16 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-30 00:50:20 -0400
commitf5ed5c7fd63b257aabcca0512e46d117121c9e16 (patch)
tree018ded597b3a25e240e384d7d257c4ca1005a9e1 /meta-openstack/recipes-support
parent010135a5b132197a784d3f337748433278f1fad8 (diff)
downloadmeta-cloud-services-f5ed5c7fd63b257aabcca0512e46d117121c9e16.tar.gz
ldap/pam authentication: package nss-pam-ldapd
Package nss-pam-ldapd, this is a daemon enabling pam/ldap authentication. Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/nss-pam-ldapd/files/nslcd.init84
-rw-r--r--meta-openstack/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.4.bb52
2 files changed, 136 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/nss-pam-ldapd/files/nslcd.init b/meta-openstack/recipes-support/nss-pam-ldapd/files/nslcd.init
new file mode 100644
index 0000000..a27b6e0
--- /dev/null
+++ b/meta-openstack/recipes-support/nss-pam-ldapd/files/nslcd.init
@@ -0,0 +1,84 @@
1#!/bin/sh
2
3set -x
4
5NAME="nslcd"
6CONFIG="/etc/nslcd.conf"
7DAEMON="/usr/sbin/nslcd"
8DESC="LDAP connection daemon"
9STATEDIR="/var/run/$NAME"
10PIDFILE="$STATEDIR/$NAME.pid"
11
12start()
13{
14 if [ -e $PIDFILE ]; then
15 PIDDIR=/proc/$(cat $PIDFILE)
16 if [ -d ${PIDDIR} ]; then
17 echo "$DESC already running."
18 exit 1
19 else
20 echo "Removing stale PID file $PIDFILE"
21 rm -f $PIDFILE
22 fi
23 fi
24
25 echo -n "Starting $DESC..."
26
27 start-stop-daemon --start --oknodo \
28 --pidfile $PIDFILE --startas $DAEMON
29
30 if [ $? -eq 0 ]; then
31 echo "done."
32 else
33 echo "failed."
34 fi
35}
36
37stop()
38{
39 echo -n "Stopping $DESC..."
40 start-stop-daemon --stop --quiet --pidfile $PIDFILE \
41 --name $NAME
42 if [ $? -eq 0 ]; then
43 echo "done."
44 else
45 echo "failed."
46 fi
47 rm -f $PIDFILE
48}
49
50status()
51{
52 if [ -f $PIDFILE ]; then
53 if $DAEMON --check
54 then
55 echo "$DESC is running (pid `cat $PIDFILE`"
56 else
57 echo "$DESC stopped"
58 fi
59 else
60 echo "$DESC stopped"
61 fi
62}
63
64case "$1" in
65 start)
66 start
67 ;;
68 stop)
69 stop
70 ;;
71 restart|force-reload|reload)
72 stop
73 start
74 ;;
75 status)
76 status
77 ;;
78 *)
79 echo "Usage: $0 {start|stop|force-reload|restart|reload|status}"
80 exit 1
81 ;;
82esac
83
84exit 0
diff --git a/meta-openstack/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.4.bb b/meta-openstack/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.4.bb
new file mode 100644
index 0000000..d7aaaf1
--- /dev/null
+++ b/meta-openstack/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.4.bb
@@ -0,0 +1,52 @@
1SUMMARY = "NSS and PAM module for using LDAP as a naming service"
2DESCRIPTION = "\
3 daemon for NSS and PAM lookups using LDAP \
4 This package provides a daemon for retrieving user accounts and similar \
5 system information from LDAP. It is used by the libnss-ldapd and \
6 libpam-ldapd packages but is not very useful by itself. \
7 "
8
9HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
10
11LICENSE = "LGPLv2.1"
12LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
13SECTION = "base"
14
15FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
16
17SRC_URI = "\
18 http://arthurdejong.org/nss-pam-ldapd/${PN}-${PV}.tar.gz \
19 file://nslcd.init\
20 "
21
22inherit autotools
23
24
25SRC_URI[md5sum] = "0d74202700efdde3b6e551bfff49c132"
26SRC_URI[sha256sum] = "fd2e3e0935acfd3d2b13682962f51d28d5855472e690d787e36a476fa40c88e6"
27
28DEPENDS += "libpam openldap"
29
30EXTRA_OECONF = "\
31 --disable-pynslcd \
32 --libdir=${base_libdir} \
33 --with-pam-seclib-dir=${base_libdir}/security \
34 "
35
36FILES_${PN} += "${base_libdir}/security ${datadir}"
37FILES_${PN}-dbg += "${base_libdir}/security/.debug"
38
39LDAP_DN ?= "dc=my-domain,dc=com"
40
41do_install_append() {
42 install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
43
44 sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
45 sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
46 sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
47}
48
49inherit update-rc.d
50
51INITSCRIPT_NAME = "nslcd"
52INITSCRIPT_PARAMS = "defaults"