summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-07-30 18:16:53 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-31 11:57:20 -0400
commite7275931b151529c343f9c5039e5d5c382b35f8b (patch)
tree110e58367518f6ff35f1365278bd7222fba4a816 /meta-openstack/recipes-support
parentf7238d1d3d127954c3460e2ad015f68f3bfe95d8 (diff)
downloadmeta-cloud-services-e7275931b151529c343f9c5039e5d5c382b35f8b.tar.gz
openldap: Fix paths
Explicitly set the libexec dir to /usr/libexec for openstack Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/openldap/files/initscript2
-rw-r--r--meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend11
2 files changed, 10 insertions, 3 deletions
diff --git a/meta-openstack/recipes-support/openldap/files/initscript b/meta-openstack/recipes-support/openldap/files/initscript
index f9c343a..51bdeff 100644
--- a/meta-openstack/recipes-support/openldap/files/initscript
+++ b/meta-openstack/recipes-support/openldap/files/initscript
@@ -6,7 +6,7 @@
6# 6#
7 7
8 8
9slapd=/usr/libexec/slapd 9slapd=%LIBEXEC%/slapd
10test -x "$slapd" || exit 0 10test -x "$slapd" || exit 0
11 11
12src_data_dir=/etc/openldap/ 12src_data_dir=/etc/openldap/
diff --git a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
index d8166ce..3f9fc7d 100644
--- a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
+++ b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
@@ -10,10 +10,15 @@ SRC_URI += "file://ops-base.ldif"
10LDAP_DN ?= "dc=my-domain,dc=com" 10LDAP_DN ?= "dc=my-domain,dc=com"
11LDAP_DATADIR ?= "/etc/openldap-data/" 11LDAP_DATADIR ?= "/etc/openldap-data/"
12 12
13OPENLDAP_LIBEXECDIR = "/usr/libexec"
14
15EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}"
16
13do_install_append() { 17do_install_append() {
14 install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap 18 install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap
15 sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap 19 sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap
16 sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap 20 sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap
21 sed -i -e 's#%LIBEXEC%#${OPENLDAP_LIBEXECDIR}#g' ${D}${sysconfdir}/init.d/openldap
17 22
18 # This is duplicated in /etc/openldap and is for slapd 23 # This is duplicated in /etc/openldap and is for slapd
19 rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example 24 rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
@@ -21,7 +26,7 @@ do_install_append() {
21 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" 26 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
22 27
23 # remove symlinks for backends, recreating in postinstall 28 # remove symlinks for backends, recreating in postinstall
24 rm ${D}/${libexecdir}/openldap/*.so 29 rm -f ${D}/${OPENLDAP_LIBEXECDIR}/openldap/*.so
25 30
26 sed -i -e '/^include\s*/a \ 31 sed -i -e '/^include\s*/a \
27include /etc/openldap/schema/cosine.schema \ 32include /etc/openldap/schema/cosine.schema \
@@ -31,7 +36,7 @@ include /etc/openldap/schema/misc.schema' \
31 ${D}/etc/openldap/slapd.conf 36 ${D}/etc/openldap/slapd.conf
32 37
33 sed -i -e '/^# Load dynamic backend modules:/a \ 38 sed -i -e '/^# Load dynamic backend modules:/a \
34modulepath /usr/libexec/openldap \ 39modulepath ${OPENLDAP_LIBEXECDIR}/openldap \
35moduleload back_bdb.la' \ 40moduleload back_bdb.la' \
36 ${D}/etc/openldap/slapd.conf 41 ${D}/etc/openldap/slapd.conf
37 42
@@ -65,3 +70,5 @@ inherit update-rc.d
65INITSCRIPT_NAME = "openldap" 70INITSCRIPT_NAME = "openldap"
66INITSCRIPT_PARAMS = "defaults" 71INITSCRIPT_PARAMS = "defaults"
67 72
73FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/*"
74FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug"