summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-19 00:47:54 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-19 09:27:52 -0400
commit81e8ddfce5d62c5f631851daefdd272051967634 (patch)
treedd46a2e1f2d5875c26456675d776b50fa0a7d1da /meta-openstack/recipes-support
parentdbe4cf0918e6c27d0d16756f48dd2951c4bab4d0 (diff)
downloadmeta-cloud-services-81e8ddfce5d62c5f631851daefdd272051967634.tar.gz
memcached: re-sync to meta-networking version
To avoid configuration errors, we need to get the latest meta-networking changes. This recipe will be dropped eventually, but will stay a bit longer for migration purposes. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/memcached/memcached/configure.patch13
-rw-r--r--meta-openstack/recipes-support/memcached/memcached_1.4.17.bb24
2 files changed, 22 insertions, 15 deletions
diff --git a/meta-openstack/recipes-support/memcached/memcached/configure.patch b/meta-openstack/recipes-support/memcached/memcached/configure.patch
new file mode 100644
index 0000000..7001a0e
--- /dev/null
+++ b/meta-openstack/recipes-support/memcached/memcached/configure.patch
@@ -0,0 +1,13 @@
1Index: memcached-1.4.17/configure.ac
2===================================================================
3--- memcached-1.4.17.orig/configure.ac 2013-12-20 21:44:49.000000000 +0000
4+++ memcached-1.4.17/configure.ac 2014-07-18 07:17:00.593499483 +0000
5@@ -4,7 +4,7 @@
6 AC_INIT(memcached, VERSION_NUMBER, memcached@googlegroups.com)
7 AC_CANONICAL_SYSTEM
8 AC_CONFIG_SRCDIR(memcached.c)
9-AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
10+AM_INIT_AUTOMAKE([foreign])
11 AM_CONFIG_HEADER(config.h)
12
13 AC_PROG_CC
diff --git a/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb b/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
index 43c826f..5d37df0 100644
--- a/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
+++ b/meta-openstack/recipes-support/memcached/memcached_1.4.17.bb
@@ -1,12 +1,5 @@
1SUMMARY = "A high-performance memory object caching system" 1SUMMARY = "A high-performance memory object caching system"
2DESCRIPTION = "\ 2DESCRIPTION = "\
3 Danga Interactive developed memcached to enhance the speed of LiveJournal.com, \
4 a site which was already doing 20 million+ dynamic page views per day for 1 \
5 million users with a bunch of webservers and a bunch of database servers. \
6 memcached dropped the database load to almost nothing, yielding faster page \
7 load times for users, better resource utilization, and faster access to the \
8 databases on a memcache miss. \
9 . \
10 memcached optimizes specific high-load serving applications that are designed \ 3 memcached optimizes specific high-load serving applications that are designed \
11 to take advantage of its versatile no-locking memory access system. Clients \ 4 to take advantage of its versatile no-locking memory access system. Clients \
12 are available in several different programming languages, to suit the needs \ 5 are available in several different programming languages, to suit the needs \
@@ -14,17 +7,18 @@ DESCRIPTION = "\
14 apps to avoid storing large chunks of data in Apache memory, and to share \ 7 apps to avoid storing large chunks of data in Apache memory, and to share \
15 this burden across several machines." 8 this burden across several machines."
16 9
17HOMEPAGE = "http://www.danga.com/memcached/" 10HOMEPAGE = "http://memcached.org/"
18LICENSE = "BSD" 11LICENSE = "BSD-3-Clause"
19 12
20LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff" 13LIC_FILES_CHKSUM = "file://COPYING;md5=7e5ded7363d335e1bb18013ca08046ff"
21 14
22inherit autotools autotools-brokensep 15inherit autotools
23 16
24DEPENDS += "libevent" 17DEPENDS += "libevent"
25RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader perl-module-tie-hash" 18RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader perl-module-tie-hash"
26 19
27SRC_URI = "http://www.memcached.org/files/${PN}-${PV}.tar.gz" 20SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
21 file://configure.patch"
28 22
29SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6" 23SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6"
30SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458" 24SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458"
@@ -43,8 +37,8 @@ INITSCRIPT_NAME = "memcached"
43INITSCRIPT_PARAMS = "defaults" 37INITSCRIPT_PARAMS = "defaults"
44 38
45do_install_append() { 39do_install_append() {
46 install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached 40 install -D -m 755 ${S}/scripts/memcached-init ${D}${sysconfdir}/init.d/memcached
47 mkdir -p ${D}/usr/share/memcached/scripts 41 mkdir -p ${D}/usr/share/memcached/scripts
48 install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts 42 install -m 755 ${S}/scripts/memcached-tool ${D}/usr/share/memcached/scripts
49 install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts 43 install -m 755 ${S}/scripts/start-memcached ${D}/usr/share/memcached/scripts
50} 44}