summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:27:14 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit52ae70c869d4057d418e3fa031e6521482768d67 (patch)
treed1e5beab08ed069e4db992f0abb3b6973c7f10a4 /meta-openstack/recipes-support
parent3197668c9c940295e7c824f8cd2b1f69949bf213 (diff)
downloadmeta-cloud-services-52ae70c869d4057d418e3fa031e6521482768d67.tar.gz
Ruby/chef solo: Add recipes-support/chef/chef_git.bb
Use chef-solo to help reconfigure and deployment of controller and compute nodes. Install script downloaded from this link (https://www.opscode.com/chef/install.sh) and the attached archives created from it. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/chef/chef_git.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/chef/chef_git.bb b/meta-openstack/recipes-support/chef/chef_git.bb
new file mode 100644
index 0000000..b2b82e6
--- /dev/null
+++ b/meta-openstack/recipes-support/chef/chef_git.bb
@@ -0,0 +1,70 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Supports the deployment of OpenStack nodes"
5DESCRIPTION = "Use chef-solo to help reconfigure and deployment of controller \
6and compute nodes. Install script downloaded from this link \
7(https://www.opscode.com/chef/install.sh) and the attached archives created from it."
8
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
11
12PR = "r0"
13
14#SRC_URI[md5sum] = "521d9184648b12e0ea331367d287314f"
15#SRC_URI[sha256sum] ="d00874468a4f9e43d6acb0d5238a50ebb4c79f17fd502741a0fc83d76eb253cf"
16
17BPV = "11.12.4"
18PV = "${BPV}"
19SRCREV = "410af3e88cf9f0793c56363563be8fa173244d3a"
20
21S = "${WORKDIR}/git"
22
23SRC_URI = " \
24 git://github.com/opscode/chef.git \
25 "
26
27inherit ruby
28
29DEPENDS += " \
30 ruby-native \
31 pry-native \
32 yard-native \
33 bundler-native \
34 "
35
36RDEPENDS += " \
37 ruby \
38 chef-zero \
39 coderay \
40 diff-lcs \
41 erubis \
42 hashie \
43 highline \
44 ipaddress \
45 json \
46 method-source \
47 mime-types \
48 mixlib-authentication \
49 mixlib-cli \
50 mixlib-config \
51 mixlib-log \
52 mixlib-shellout \
53 net-ssh \
54 net-ssh-gateway \
55 net-ssh-multi \
56 ohai \
57 pry \
58 rack \
59 rest-client \
60 slop \
61 systemu \
62 yajl-ruby \
63 make \
64 "
65
66RUBY_INSTALL_GEMS = "pkg/chef-${BPV}.gem"
67
68do_install_prepend() {
69 rake gem
70}