summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support
diff options
context:
space:
mode:
authorLei Maohui <leimaohui@cn.fujitsu.com>2015-08-07 17:14:24 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-08-10 09:50:32 -0400
commit3f29b407bca6b6bd2dc0e21983785e5844397419 (patch)
treee044e1bb587321a7a96c9c5108533e08c571de1f /meta-openstack/recipes-support
parentf62db5292c8a7f8d01944a8b6a175ed216c8d72c (diff)
downloadmeta-cloud-services-3f29b407bca6b6bd2dc0e21983785e5844397419.tar.gz
chef: upgrade 11.12.4->12.4.1
Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support')
-rw-r--r--meta-openstack/recipes-support/chef/chef/0001-chang-ksh-to-sh.patch23
-rw-r--r--meta-openstack/recipes-support/chef/chef_git.bb14
2 files changed, 31 insertions, 6 deletions
diff --git a/meta-openstack/recipes-support/chef/chef/0001-chang-ksh-to-sh.patch b/meta-openstack/recipes-support/chef/chef/0001-chang-ksh-to-sh.patch
new file mode 100644
index 0000000..b3d13fc
--- /dev/null
+++ b/meta-openstack/recipes-support/chef/chef/0001-chang-ksh-to-sh.patch
@@ -0,0 +1,23 @@
1From b819187d45984b4bc37aebc41570a7f4fff94b14 Mon Sep 17 00:00:00 2001
2From: Lei Maohui <leimaohui@cn.fujitsu.com>
3Date: Tue, 4 Aug 2015 03:56:28 +0900
4Subject: [PATCH] chang ksh to sh
5
6Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
7---
8 spec/functional/assets/chefinittest | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/spec/functional/assets/chefinittest b/spec/functional/assets/chefinittest
12index 79e064c..46a7c3b 100755
13--- a/spec/functional/assets/chefinittest
14+++ b/spec/functional/assets/chefinittest
15@@ -1,4 +1,4 @@
16-#!/bin/ksh
17+#!/bin/sh
18
19 function create_chef_txt {
20 touch /tmp/chefinittest.txt
21--
221.8.4.2
23
diff --git a/meta-openstack/recipes-support/chef/chef_git.bb b/meta-openstack/recipes-support/chef/chef_git.bb
index c8a422b..86e4165 100644
--- a/meta-openstack/recipes-support/chef/chef_git.bb
+++ b/meta-openstack/recipes-support/chef/chef_git.bb
@@ -11,17 +11,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
11 11
12PR = "r0" 12PR = "r0"
13 13
14#SRC_URI[md5sum] = "521d9184648b12e0ea331367d287314f" 14BPV = "12.4.1"
15#SRC_URI[sha256sum] ="d00874468a4f9e43d6acb0d5238a50ebb4c79f17fd502741a0fc83d76eb253cf"
16
17BPV = "11.12.4"
18PV = "${BPV}" 15PV = "${BPV}"
19SRCREV = "410af3e88cf9f0793c56363563be8fa173244d3a" 16SRCREV = "1dc20627aa5d742376269dc5b4d5c67f34d08008"
20 17
21S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
22 19
23SRC_URI = " \ 20SRC_URI = " \
24 git://github.com/opscode/chef.git;branch=11-stable \ 21 git://github.com/opscode/chef.git;branch=12.4-stable \
22 file://0001-chang-ksh-to-sh.patch \
25 " 23 "
26 24
27inherit ruby 25inherit ruby
@@ -61,10 +59,14 @@ RDEPENDS_${PN} += " \
61 systemu \ 59 systemu \
62 yajl-ruby \ 60 yajl-ruby \
63 make \ 61 make \
62 bash \
64 " 63 "
65 64
66RUBY_INSTALL_GEMS = "pkg/chef-${BPV}.gem" 65RUBY_INSTALL_GEMS = "pkg/chef-${BPV}.gem"
67 66
67FILES_${PN} += "${libdir}/ruby/gems/2.2.0/build_info"
68FILES_${PN} += "${libdir}/ruby/gems/2.2.0/extensions"
69
68do_install_prepend() { 70do_install_prepend() {
69 rake gem 71 rake gem
70} 72}