summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/tgt
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-09 10:04:23 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-09 12:23:58 -0500
commit96dd0da3edc2f56de99d84ef96effdbf366a3041 (patch)
treedea117cada6afeadcd683dee49c1914dab5f2462 /meta-openstack/recipes-support/tgt
parentf2c4ac24f1daff78fd4f93af073aa0a7f5b82c31 (diff)
downloadmeta-cloud-services-96dd0da3edc2f56de99d84ef96effdbf366a3041.tar.gz
tgt: ensure build LDFLAGS apply to all executables
Some of the tgt executables were not being built with the gnu-hash causing a QA error. There is no apparent reason to have differences in how the tgt executables are built so ensure they all use the LDFLAGS. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-support/tgt')
-rw-r--r--meta-openstack/recipes-support/tgt/files/0001-usr-Makefile-WARNING-fix.patch2
-rw-r--r--meta-openstack/recipes-support/tgt/files/usr-Makefile-apply-LDFLAGS-to-all-executables.patch35
-rw-r--r--meta-openstack/recipes-support/tgt/tgt_git.bb8
3 files changed, 41 insertions, 4 deletions
diff --git a/meta-openstack/recipes-support/tgt/files/0001-usr-Makefile-WARNING-fix.patch b/meta-openstack/recipes-support/tgt/files/0001-usr-Makefile-WARNING-fix.patch
index 15f5482..f749101 100644
--- a/meta-openstack/recipes-support/tgt/files/0001-usr-Makefile-WARNING-fix.patch
+++ b/meta-openstack/recipes-support/tgt/files/0001-usr-Makefile-WARNING-fix.patch
@@ -22,7 +22,7 @@ index 1fae7e7..2db109c 100644
22 TGTD_DEP = $(TGTD_OBJS:.o=.d) 22 TGTD_DEP = $(TGTD_OBJS:.o=.d)
23 23
24-LDFLAGS = -Wl,-E,-rpath=$(libdir) 24-LDFLAGS = -Wl,-E,-rpath=$(libdir)
25+LDFLAGS = -Wl,-E 25+LDFLAGS += -Wl,-E
26 26
27 .PHONY:all 27 .PHONY:all
28 all: $(PROGRAMS) $(MODULES) 28 all: $(PROGRAMS) $(MODULES)
diff --git a/meta-openstack/recipes-support/tgt/files/usr-Makefile-apply-LDFLAGS-to-all-executables.patch b/meta-openstack/recipes-support/tgt/files/usr-Makefile-apply-LDFLAGS-to-all-executables.patch
new file mode 100644
index 0000000..d480ef7
--- /dev/null
+++ b/meta-openstack/recipes-support/tgt/files/usr-Makefile-apply-LDFLAGS-to-all-executables.patch
@@ -0,0 +1,35 @@
1From a815ac8ee16b344d9e24b445957f32bf2aafa532 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Thu, 5 Jan 2017 11:07:51 -0500
4Subject: [PATCH] usr/Makefile: apply LDFLAGS to all executables
5
6Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
7---
8 usr/Makefile | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/usr/Makefile b/usr/Makefile
12index cc8df11..c55fd68 100644
13--- a/usr/Makefile
14+++ b/usr/Makefile
15@@ -78,7 +78,7 @@ TGTADM_OBJS = tgtadm.o concat_buf.o
16 TGTADM_DEP = $(TGTADM_OBJS:.o=.d)
17
18 tgtadm: $(TGTADM_OBJS)
19- $(CC) $^ -o $@
20+ $(CC) $^ -o $@ $(LDFLAGS)
21
22 -include $(TGTADM_DEP)
23
24@@ -86,7 +86,7 @@ TGTIMG_OBJS = tgtimg.o libssc.o libcrc32c.o
25 TGTIMG_DEP = $(TGTIMG_OBJS:.o=.d)
26
27 tgtimg: $(TGTIMG_OBJS)
28- $(CC) $^ -o $@
29+ $(CC) $^ -o $@ $(LDFLAGS)
30
31 -include $(TGTIMG_DEP)
32
33--
342.7.4
35
diff --git a/meta-openstack/recipes-support/tgt/tgt_git.bb b/meta-openstack/recipes-support/tgt/tgt_git.bb
index 5c594b1..9ca181a 100644
--- a/meta-openstack/recipes-support/tgt/tgt_git.bb
+++ b/meta-openstack/recipes-support/tgt/tgt_git.bb
@@ -10,6 +10,7 @@ PV = "1.0.67+git${SRCPV}"
10SRC_URI = "git://github.com/fujita/tgt.git \ 10SRC_URI = "git://github.com/fujita/tgt.git \
11 file://0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch \ 11 file://0001-Correct-the-path-of-header-files-check-in-Yocto-buil.patch \
12 file://0001-usr-Makefile-WARNING-fix.patch \ 12 file://0001-usr-Makefile-WARNING-fix.patch \
13 file://usr-Makefile-apply-LDFLAGS-to-all-executables.patch \
13" 14"
14SRC_URI += "file://tgtd.init" 15SRC_URI += "file://tgtd.init"
15 16
@@ -21,9 +22,10 @@ inherit update-rc.d
21 22
22CFLAGS += ' -I. -DUSE_SIGNALFD -DUSE_TIMERFD -D_GNU_SOURCE -DTGT_VERSION=\\"1.0.63\\" -DBSDIR=\\"${libdir}/backing-store\\"' 23CFLAGS += ' -I. -DUSE_SIGNALFD -DUSE_TIMERFD -D_GNU_SOURCE -DTGT_VERSION=\\"1.0.63\\" -DBSDIR=\\"${libdir}/backing-store\\"'
23 24
24do_compile() { 25#do_compile() {
25 oe_runmake SYSROOT="${STAGING_DIR_TARGET}" -e programs conf scripts 26# oe_runmake SYSROOT="${STAGING_DIR_TARGET}" -e programs conf scripts
26} 27#}
28EXTRA_OEMAKE = "-e programs conf scripts"
27 29
28do_install() { 30do_install() {
29 oe_runmake -e DESTDIR="${D}" install-programs install-conf install-scripts 31 oe_runmake -e DESTDIR="${D}" install-programs install-conf install-scripts