summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/tgt/tgt_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-07-31 23:31:13 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-07-31 23:49:54 -0400
commit0cffcd09a44b2a58452a5bb13714bfc47d6546bf (patch)
treeb91584b573ce42431a35a9b8f064d8be57974e1e /meta-openstack/recipes-support/tgt/tgt_git.bb
parente887a996155f8b9f22d6aca0e31b5fbccd82751e (diff)
downloadmeta-cloud-services-0cffcd09a44b2a58452a5bb13714bfc47d6546bf.tar.gz
global: overrides conversion
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-support/tgt/tgt_git.bb')
-rw-r--r--meta-openstack/recipes-support/tgt/tgt_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-openstack/recipes-support/tgt/tgt_git.bb b/meta-openstack/recipes-support/tgt/tgt_git.bb
index 5242dd5..d74de4e 100644
--- a/meta-openstack/recipes-support/tgt/tgt_git.bb
+++ b/meta-openstack/recipes-support/tgt/tgt_git.bb
@@ -19,12 +19,12 @@ SRC_URI += "file://tgtd.init \
19 19
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21 21
22CONFFILES_${PN} += "${sysconfdir}/tgt/targets.conf" 22CONFFILES:${PN} += "${sysconfdir}/tgt/targets.conf"
23 23
24inherit update-rc.d systemd 24inherit update-rc.d systemd
25 25
26SYSTEMD_SERVICE_${PN} = "tgtd.service" 26SYSTEMD_SERVICE:${PN} = "tgtd.service"
27SYSTEMD_AUTO_ENABLE_${PN} = "disable" 27SYSTEMD_AUTO_ENABLE:${PN} = "disable"
28 28
29CFLAGS += ' -I. -DUSE_SIGNALFD -DUSE_TIMERFD -D_GNU_SOURCE -DTGT_VERSION=\\"1.0.63\\" -DBSDIR=\\"${libdir}/backing-store\\"' 29CFLAGS += ' -I. -DUSE_SIGNALFD -DUSE_TIMERFD -D_GNU_SOURCE -DTGT_VERSION=\\"1.0.63\\" -DBSDIR=\\"${libdir}/backing-store\\"'
30 30
@@ -50,11 +50,11 @@ do_install() {
50 fi 50 fi
51} 51}
52 52
53FILES_${PN} += "${systemd_unitdir}/system/tgtd.service \ 53FILES:${PN} += "${systemd_unitdir}/system/tgtd.service \
54 ${sysconfdir}/sysconfig/tgtd \ 54 ${sysconfdir}/sysconfig/tgtd \
55" 55"
56 56
57RDEPENDS_${PN} = " \ 57RDEPENDS:${PN} = " \
58 bash \ 58 bash \
59 libaio \ 59 libaio \
60 libconfig-general-perl \ 60 libconfig-general-perl \
@@ -88,5 +88,5 @@ RDEPENDS_${PN} = " \
88 perl-module-constant \ 88 perl-module-constant \
89 " 89 "
90INITSCRIPT_PACKAGES = "${PN}" 90INITSCRIPT_PACKAGES = "${PN}"
91INITSCRIPT_NAME_${PN} = "tgtd" 91INITSCRIPT_NAME:${PN} = "tgtd"
92 92