summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/tempest/tempest_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-11-14 23:10:02 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:38 -0500
commit0f736029c73ae9b921ef67490d2086520e2e2c28 (patch)
tree7ba8d2815c2084bebc99f61d593600ccbd056d38 /meta-openstack/recipes-extended/tempest/tempest_git.bb
parentd36d9a4408b2432175ce824b39952f732ac156d1 (diff)
downloadmeta-cloud-services-0f736029c73ae9b921ef67490d2086520e2e2c28.tar.gz
tempest: introduce the openstack unit test framework
Introduce the OpenStack test framework "tempest". This initial integration makes the framework available, but does not enable it in any images by default, nor does it stage the tests for execution. Subsequent updates will modify this baseline for test execution and reporting. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-extended/tempest/tempest_git.bb')
-rw-r--r--meta-openstack/recipes-extended/tempest/tempest_git.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/meta-openstack/recipes-extended/tempest/tempest_git.bb b/meta-openstack/recipes-extended/tempest/tempest_git.bb
new file mode 100644
index 0000000..250e541
--- /dev/null
+++ b/meta-openstack/recipes-extended/tempest/tempest_git.bb
@@ -0,0 +1,93 @@
1DESCRIPTION = "The OpenStack Integration Test Suite"
2HOMEPAGE = "https://launchpad.net/tempest"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PR = "r0"
8SRCNAME = "tempest"
9
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
11 file://tempest.conf \
12 file://logging.conf \
13"
14
15SRCREV="6273339e2da725b01560b6a2db11a3bf7a6659d7"
16PV="2013.2+git${SRCPV}"
17S = "${WORKDIR}/git"
18
19do_install_append() {
20 TEMPLATE_CONF_DIR=${S}${sysconfdir}/
21 TEMPEST_CONF_DIR=${D}${sysconfdir}/${SRCNAME}
22
23 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${WORKDIR}/tempest.conf
24 sed -e "s:%SERVICE_USER%:${SRCNAME}:g" -i ${WORKDIR}/tempest.conf
25 sed -e "s:%SERVICE_PASSWORD%:${SERVICE_PASSWORD}:g" -i ${WORKDIR}/tempest.conf
26
27 sed -e "s:%DB_USER%:${DB_USER}:g" -i ${WORKDIR}/tempest.conf
28 sed -e "s:%DB_PASSWORD%:${DB_PASSWORD}:g" -i ${WORKDIR}/tempest.conf
29
30 sed -e "s:%CONTROLLER_IP%:${CONTROLLER_IP}:g" -i ${WORKDIR}/tempest.conf
31 sed -e "s:%CONTROLLER_HOST%:${CONTROLLER_HOST}:g" -i ${WORKDIR}/tempest.conf
32
33 sed -e "s:%COMPUTE_IP%:${COMPUTE_IP}:g" -i ${WORKDIR}/tempest.conf
34 sed -e "s:%COMPUTE_HOST%:${COMPUTE_HOST}:g" -i ${WORKDIR}/tempest.conf
35
36 sed -e "s:%ADMIN_PASSWORD%:${ADMIN_PASSWORD}:g" -i ${WORKDIR}/tempest.conf
37 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${WORKDIR}/tempest.conf
38
39 install -d ${TEMPEST_CONF_DIR}
40 install -m 600 ${WORKDIR}/tempest.conf ${TEMPEST_CONF_DIR}
41 install -m 600 ${WORKDIR}/logging.conf ${TEMPEST_CONF_DIR}
42 install -m 600 ${TEMPLATE_CONF_DIR}/*.yaml ${TEMPEST_CONF_DIR}
43}
44
45pkg_postinst_${SRCNAME}() {
46 if [ "x$D" != "x" ]; then
47 exit 1
48 fi
49
50 # This is to make sure postgres is configured and running
51 if ! pidof postmaster > /dev/null; then
52 /etc/init.d/postgresql-init
53 /etc/init.d/postgresql start
54 sleep 5
55 fi
56}
57
58inherit setuptools identity hosts
59
60# PACKAGES += "${SRCNAME}-common ${SRCNAME}-api ${SRCNAME}-api-cfn ${SRCNAME}-engine"
61
62FILES_${PN} = "${libdir}/* \
63 ${sysconfdir}/* \
64"
65
66RDEPENDS_${PN} += " \
67 python-testrepository \
68 python-fixtures \
69 python-keyring \
70 python-glanceclient \
71 python-keystoneclient \
72 python-swiftclient \
73 python-novaclient \
74 python-cinderclient \
75 python-heatclient \
76 python-pbr \
77 python-anyjson \
78 python-nose \
79 python-httplib2 \
80 python-jsonschema \
81 python-testtools \
82 python-lxml \
83 python-boto \
84 python-paramiko \
85 python-netaddr \
86 python-testresources \
87 python-oslo.config \
88 python-eventlet \
89 python-six \
90 python-iso8601 \
91 python-mimeparse \
92 "
93