summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/rabbitmq
diff options
context:
space:
mode:
authorMustapha Lansana <Mustapha.Lansana@windriver.com>2014-06-04 09:46:44 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-09 09:31:18 -0400
commit0a227428033c4b32857d2ed4b827f2342ada84df (patch)
tree474109b79d295ccf54b4ae7daa28c8ab33738086 /meta-openstack/recipes-extended/rabbitmq
parent1a21748b3cd2476e99f7326efebc3aaa87772ed8 (diff)
downloadmeta-cloud-services-0a227428033c4b32857d2ed4b827f2342ada84df.tar.gz
meta-openstack/rabbitmq-server: QA Warning found-reference to /usr
When populating the Openstack rootfs with rabbitmq-server package, you get the following warnings: WARNING: QA Issue: rabbitmq-server: Found a reference to /usr/ in rabbitmq-server-3.2.4-r2/packages-split/rabbitmq-server/sbin/rabbitmq-env WARNING: QA Issue: Shell scripts in base_bindir and base_sbindir should not reference anything in exec_prefix This patch silence the warning by telling the build system to not throw warnings if a script in base_[bindir | sbindir | libdir ] makes what it considers an unsafe reference to exec_prefix. The reference though to exec_prefix in this case is very safe, since it is only part of variable directing other scripts to rabbitmq-server's plugins directory. Signed-off-by: Mustapha Lansana <Mustapha.Lansana@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-extended/rabbitmq')
-rw-r--r--meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb b/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb
index 1c5344d..5f080e3 100644
--- a/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb
+++ b/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb
@@ -4,7 +4,7 @@ LICENSE = "MPL-1.1"
4LIC_FILES_CHKSUM = "file://LICENSE-MPL-RabbitMQ;md5=b651d0a6feaaf2bf5eb9d36b2495c510" 4LIC_FILES_CHKSUM = "file://LICENSE-MPL-RabbitMQ;md5=b651d0a6feaaf2bf5eb9d36b2495c510"
5SECTION = "network" 5SECTION = "network"
6DEPENDS = "erlang-native libxslt python-simplejson zip-native unzip-native libxslt-native" 6DEPENDS = "erlang-native libxslt python-simplejson zip-native unzip-native libxslt-native"
7PR = "r1" 7PR = "r2"
8 8
9SRC_URI = "http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/${PN}-${PV}.tar.gz \ 9SRC_URI = "http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/${PN}-${PV}.tar.gz \
10 file://rabbitmq-server \ 10 file://rabbitmq-server \
@@ -59,3 +59,4 @@ FILES_${PN} += " ${libdir}/rabbitmq/lib/${PN}-${PV}/* \
59 " 59 "
60 60
61FILES_${PN}-doc += "LICENSE* INSTALL" 61FILES_${PN}-doc += "LICENSE* INSTALL"
62INSANE_SKIP_${PN} = "unsafe-references-in-scripts"