summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/images
diff options
context:
space:
mode:
authorVu Tran <vu.tran@windriver.com>2014-09-30 12:22:12 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-30 14:30:18 -0400
commitb4d666ff63acd269b0acb2c4419643863c683750 (patch)
treef22e20ee845a0cca1fe0f7837d92a652325ba036 /meta-openstack/recipes-extended/images
parent1b8a298689a95c1943f18d8d9c24589e64bbc7b7 (diff)
downloadmeta-cloud-services-b4d666ff63acd269b0acb2c4419643863c683750.tar.gz
add generic monitor framework
Instead of having a central file or group of files to describe what data resources should be monitored. The content of these files will depend on what core system monitoring is used ((e.g. Nagios or Monasca). It's desirable to have each recipe describes what it wants be monitored in generic way such that various system monitors can understand and convert these into their format. If a recipe wishes to register itself to system monitor, it inherits monitor bbclass and use MONITOR_SERVICE_PACKAGES and MONITOR_SERVICE_<package name> to indicate what processes should should be monitored. Also MONITOR_CHECKS_<package name> variale can be used to pass list of scripts which will be run on target and if any of these scripts fail then will report. Eventually monitor.bbclass will be expanded to allow recipe to describe more complicated information passed down to system monitor (e.g. Nagios or Monasca) Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-extended/images')
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-aio.bb1
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-compute.bb1
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-controller.bb1
3 files changed, 3 insertions, 0 deletions
diff --git a/meta-openstack/recipes-extended/images/openstack-image-aio.bb b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
index 3aff066..ec34770 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-aio.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-aio.bb
@@ -25,6 +25,7 @@ IMAGE_FEATURES += "ssh-server-openssh"
25inherit core-image 25inherit core-image
26inherit openstack-base 26inherit openstack-base
27inherit identity 27inherit identity
28inherit monitor
28 29
29# check for 5G of free space, so we use 5G as a starting point. 30# check for 5G of free space, so we use 5G as a starting point.
30IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 5000000" 31IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 5000000"
diff --git a/meta-openstack/recipes-extended/images/openstack-image-compute.bb b/meta-openstack/recipes-extended/images/openstack-image-compute.bb
index e9f90e8..979e525 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-compute.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-compute.bb
@@ -16,6 +16,7 @@ IMAGE_FEATURES += "ssh-server-openssh"
16 16
17inherit core-image 17inherit core-image
18inherit openstack-base 18inherit openstack-base
19inherit monitor
19 20
20# Ensure extra space for guest images, and rabbit MQ has a hard coded 21# Ensure extra space for guest images, and rabbit MQ has a hard coded
21# check for 2G of free space, so we use 3G as a starting point. 22# check for 2G of free space, so we use 3G as a starting point.
diff --git a/meta-openstack/recipes-extended/images/openstack-image-controller.bb b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
index d2cc90f..a410acf 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-controller.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
@@ -21,6 +21,7 @@ POST_KEYSTONE_SETUP_COMMAND = "/etc/keystone/hybrid-backend-setup"
21inherit core-image 21inherit core-image
22inherit openstack-base 22inherit openstack-base
23inherit identity 23inherit identity
24inherit monitor
24 25
25# Ensure extra space for guest images, and rabbit MQ has a hard coded 26# Ensure extra space for guest images, and rabbit MQ has a hard coded
26# check for 2G of free space, so we use 5G as a starting point. 27# check for 2G of free space, so we use 5G as a starting point.