summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/images
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-02 09:37:19 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-03 01:16:44 -0400
commit793fbb775b5ec344434031647be2b5befe3159c8 (patch)
tree9b3081b9b31dc1f096c618de441bd8d94047c61f /meta-openstack/recipes-extended/images
parent45c125cd53f69a9ced0ed2841d86977a8bfdb88f (diff)
downloadmeta-cloud-services-793fbb775b5ec344434031647be2b5befe3159c8.tar.gz
openstack: compute node image free space and deployment
Various components (such as rabbitmq) have checks for minimum amounts of free space on a image. If those checks fail, the service exits in a hard to debug manner. To ensure that these services run, and meet typical usage scenarios, we increase the free space in the image to 3G. Finally, we inherit openstack-image-base, to trigger simple rootfs configuration and deployment. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-extended/images')
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-compute.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-openstack/recipes-extended/images/openstack-image-compute.bb b/meta-openstack/recipes-extended/images/openstack-image-compute.bb
index 632b21b..2ddce67 100644
--- a/meta-openstack/recipes-extended/images/openstack-image-compute.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-compute.bb
@@ -10,7 +10,10 @@ IMAGE_INSTALL = " \
10IMAGE_FEATURES += "ssh-server-openssh" 10IMAGE_FEATURES += "ssh-server-openssh"
11 11
12inherit core-image 12inherit core-image
13inherit openstack-base
13 14
14#IMAGE_ROOTFS_EXTRA_SPACE = "41943040" 15# Ensure extra space for guest images, and rabbit MQ has a hard coded
16# check for 2G of free space, so we use 3G as a starting point.
17IMAGE_ROOTFS_EXTRA_SPACE = "3000000"
15 18
16ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; " 19ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "