summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-extended/cloud-init
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-11 09:53:34 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-16 00:19:43 -0400
commit4126e86dfb455cceba9eaa44144210e51bf53cc2 (patch)
tree506357a7ee0e929caee727bb84fda0915143e2a2 /meta-openstack/recipes-extended/cloud-init
parent68093df0df2c3b9765cf5ca1728cfee12da322bc (diff)
downloadmeta-cloud-services-4126e86dfb455cceba9eaa44144210e51bf53cc2.tar.gz
cloud-init: install to correct target directory
The setup.py script that is included with the cloud-init code is setup to install files into the "/usr/lib" directory. On 64-bit machines the target directory should be "/usr/lib64". This generates a warning when using bitbake. This fix performs a search and replace on the setup.py file to set the correct output directory. This fix also adds a symbolic link to each script from the /etc/cloud directory to make the scripts available from a more obvious location. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-extended/cloud-init')
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.4.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.4.bb b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.4.bb
index 57f689d..9e460a7 100644
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.4.bb
+++ b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.4.bb
@@ -22,10 +22,17 @@ DISTUTILS_INSTALL_ARGS_append = " ${@base_contains('DISTRO_FEATURES', 'systemd',
22MANAGE_HOSTS ?= "False" 22MANAGE_HOSTS ?= "False"
23HOSTNAME ?= "" 23HOSTNAME ?= ""
24 24
25do_install_prepend() {
26 sed -e 's:/usr/lib/${BPN}:${libdir}/${BPN}:' -i ${S}/setup.py
27}
28
25do_install_append() { 29do_install_append() {
26 sed -e "s:%MANAGE_HOSTS%:${MANAGE_HOSTS}:g" -i ${WORKDIR}/cloud.cfg 30 sed -e "s:%MANAGE_HOSTS%:${MANAGE_HOSTS}:g" -i ${WORKDIR}/cloud.cfg
27 sed -e "s:%HOSTNAME%:${HOSTNAME}:g" -i ${WORKDIR}/cloud.cfg 31 sed -e "s:%HOSTNAME%:${HOSTNAME}:g" -i ${WORKDIR}/cloud.cfg
28 install -m 0755 ${WORKDIR}/cloud.cfg ${D}${sysconfdir}/cloud/cloud.cfg 32 install -m 0755 ${WORKDIR}/cloud.cfg ${D}${sysconfdir}/cloud/cloud.cfg
33
34 ln -s ${libdir}/${BPN}/uncloud-init ${D}${sysconfdir}/cloud/uncloud-init
35 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints
29} 36}
30 37
31inherit setuptools update-rc.d 38inherit setuptools update-rc.d