summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-07-28 09:20:03 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-30 15:47:33 -0400
commitde4ebbed303b40bb3270a4b793bb1469418c7d6e (patch)
tree045a6794daabbdae280aa49470ff5ac07a44b591 /meta-openstack/recipes-devtools
parentb3006772734204e678d641ae1659f98e86ad5ee7 (diff)
downloadmeta-cloud-services-de4ebbed303b40bb3270a4b793bb1469418c7d6e.tar.gz
python3-zaqarclient: Change to python3
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-zaqarclient_git.bb37
-rw-r--r--meta-openstack/recipes-devtools/python/python3-zaqarclient_2.0.0.bb34
2 files changed, 34 insertions, 37 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-zaqarclient_git.bb b/meta-openstack/recipes-devtools/python/python-zaqarclient_git.bb
deleted file mode 100644
index 47b28f3..0000000
--- a/meta-openstack/recipes-devtools/python/python-zaqarclient_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "Python Zaqar Client"
2HOMEPAGE = "https://github.com/openstack/python-zaqarclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7DEPENDS += " \
8 python-pip \
9 python-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15 "
16
17RDEPENDS_${PN} +=" \
18 python-pbr \
19 python-requests \
20 python-six \
21 python-stevedore \
22 python-jsonschema \
23 python-oslo.i18n \
24 python-oslo.log \
25 python-oslo.utils \
26 python-keystoneauth1 \
27 python-osc-lib \
28 "
29
30SRCNAME = "zaqarclient"
31SRC_URI = "git://github.com/openstack/${BPN}.git"
32
33PV = "1.12.0+git${SRCPV}"
34SRCREV = "9038bf6ba93c24c9a61447dfcb14e436f1267066"
35S = "${WORKDIR}/git"
36
37inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-zaqarclient_2.0.0.bb b/meta-openstack/recipes-devtools/python/python3-zaqarclient_2.0.0.bb
new file mode 100644
index 0000000..89c3081
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-zaqarclient_2.0.0.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Python Zaqar Client"
2HOMEPAGE = "https://github.com/openstack/python-zaqarclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRC_URI[sha256sum] = "c64e74d1f69321cb2f33721974c793cac1172eb8397056dfc39a7eb3d9c036de"
8
9DEPENDS += " \
10 python3-pip \
11 python3-pbr \
12 "
13
14# Satisfy setup.py 'setup_requires'
15DEPENDS += " \
16 python3-pbr-native \
17 "
18
19RDEPENDS_${PN} +=" \
20 python3-pbr \
21 python3-requests \
22 python3-six \
23 python3-stevedore \
24 python3-jsonschema \
25 python3-oslo.i18n \
26 python3-oslo.log \
27 python3-oslo.utils \
28 python3-keystoneauth1 \
29 python3-osc-lib \
30 "
31
32PYPI_PACKAGE = "python-zaqarclient"
33
34inherit setuptools3 pypi