summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 14:30:01 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:33 -0500
commitd29fdda5bdcabd4a08d003444b5c759e62b10ddc (patch)
tree74b4b49b31761dafcf622d9e3595fe68144bc89e /meta-openstack/recipes-devtools
parent7f8515a99c42f3fbe1b17a9452815df0f4822302 (diff)
downloadmeta-cloud-services-d29fdda5bdcabd4a08d003444b5c759e62b10ddc.tar.gz
python-coverage: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-coverage.inc18
-rw-r--r--meta-openstack/recipes-devtools/python/python-coverage_4.0a5.bb20
-rw-r--r--meta-openstack/recipes-devtools/python/python3-coverage_4.0a5.bb2
3 files changed, 22 insertions, 18 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-coverage.inc b/meta-openstack/recipes-devtools/python/python-coverage.inc
new file mode 100644
index 0000000..f1c5022
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-coverage.inc
@@ -0,0 +1,18 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4DESCRIPTION = "Code coverage measurement for Python"
5HOMEPAGE = "https://pypi.python.org/pypi/coverage"
6SECTION = "devel/python"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb"
9
10SRC_URI[md5sum] = "37f4d8ae679b2c43a87da8d519817a3b"
11SRC_URI[sha256sum] = "07a36ac3c82f5961c45565fd5575b4c568a8fc59e8d5d29a5b04dc8597a07e0e"
12
13inherit pypi
14
15DEPENDS += " \
16 ${PYTHON_PN}-pip \
17 "
18
diff --git a/meta-openstack/recipes-devtools/python/python-coverage_4.0a5.bb b/meta-openstack/recipes-devtools/python/python-coverage_4.0a5.bb
index 9e63221..0ddc356 100644
--- a/meta-openstack/recipes-devtools/python/python-coverage_4.0a5.bb
+++ b/meta-openstack/recipes-devtools/python/python-coverage_4.0a5.bb
@@ -1,18 +1,2 @@
1# 1require python-coverage.inc
2# Copyright (C) 2014 Wind River Systems, Inc. 2inherit setuptools
3#
4DESCRIPTION = "Code coverage measurement for Python"
5HOMEPAGE = "https://pypi.python.org/pypi/coverage"
6SECTION = "devel/python"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb"
9
10SRC_URI[md5sum] = "37f4d8ae679b2c43a87da8d519817a3b"
11SRC_URI[sha256sum] = "07a36ac3c82f5961c45565fd5575b4c568a8fc59e8d5d29a5b04dc8597a07e0e"
12
13inherit setuptools pypi
14
15DEPENDS += " \
16 python-pip \
17 "
18
diff --git a/meta-openstack/recipes-devtools/python/python3-coverage_4.0a5.bb b/meta-openstack/recipes-devtools/python/python3-coverage_4.0a5.bb
new file mode 100644
index 0000000..917a06c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-coverage_4.0a5.bb
@@ -0,0 +1,2 @@
1require python-coverage.inc
2inherit setuptools3