summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-18 09:59:26 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-23 12:23:13 -0400
commitcbc0192694da6436cfe14b57b46bcea566c97396 (patch)
treedce80dfa1a26bd51c87b3d9163e86ad7c58f8fbe /meta-openstack/recipes-devtools
parent67b60c4207fa4856f13ccbbb0543aac05030ffde (diff)
downloadmeta-cloud-services-cbc0192694da6436cfe14b57b46bcea566c97396.tar.gz
nova: use absolute path to api-paste.ini file
The api-paste.ini file shipped with nova is installed into the /etc/nova directory on a target system. The tests included with nova expect the file to be relative to the location of the tests within the source tree. This fix sets the absolute path to the api-paste.ini file as it exists on the system. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova/nova-convert-path-from-relative-to-absolute.patch33
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova/nova-convert-path-from-relative-to-absolute.patch b/meta-openstack/recipes-devtools/python/python-nova/nova-convert-path-from-relative-to-absolute.patch
new file mode 100644
index 0000000..0dba960
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-nova/nova-convert-path-from-relative-to-absolute.patch
@@ -0,0 +1,33 @@
1From 8fbdaba5c172dd95c08a808a3ec12309461ffbdb Mon Sep 17 00:00:00 2001
2From: Keith Holman <Keith.Holman@windriver.com>
3Date: Tue, 17 Jun 2014 14:34:27 -0400
4Subject: [PATCH] nova: convert path from relative to absolute
5
6Nova requires the configuration file "api-paste.ini". It is currently
7installed to the "/etc/nova/" directory. Nova assumes that this
8directory is accessible relative to the current location of source
9files. This works if the files are stored in the source tree,
10however, in deployment this doesn't work. This patch changes the path
11to the absolute path on the deployed system.
12
13Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
14---
15 nova/tests/conf_fixture.py | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/nova/tests/conf_fixture.py b/nova/tests/conf_fixture.py
19index f8e6dda..f8935f9 100644
20--- a/nova/tests/conf_fixture.py
21+++ b/nova/tests/conf_fixture.py
22@@ -48,7 +48,7 @@ class ConfFixture(fixtures.Fixture):
23 super(ConfFixture, self).setUp()
24
25 self.conf.set_default('api_paste_config',
26- paths.state_path_def('etc/nova/api-paste.ini'))
27+ paths.state_path_def('/etc/nova/api-paste.ini'))
28 self.conf.set_default('host', 'fake-mini')
29 self.conf.set_default('compute_driver', 'nova.virt.fake.FakeDriver')
30 self.conf.set_default('fake_network', True)
31--
321.9.3
33
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index 510766b..a6d5fc8 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -13,6 +13,7 @@ FILESEXTRAPATHS := "${THISDIR}/${PN}"
13 13
14SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \ 14SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \
15 file://nova-add-migrate.cfg-to-the-MANIFEST.patch \ 15 file://nova-add-migrate.cfg-to-the-MANIFEST.patch \
16 file://nova-convert-path-from-relative-to-absolute.patch \
16 " 17 "
17 18
18SRC_URI += "file://nova-all \ 19SRC_URI += "file://nova-all \