summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 16:55:20 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:32 -0500
commit9a6678bfaacfa219e4e75a260c34f76f381d5a72 (patch)
tree5703f1004b93f76df095114a9f6119d23f62e359 /meta-openstack/recipes-devtools
parent338225dbae4c536c09fb0b941188b0e75f73dd14 (diff)
downloadmeta-cloud-services-9a6678bfaacfa219e4e75a260c34f76f381d5a72.tar.gz
python-xstatic-jquery: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-jquery.inc22
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-jquery_1.10.2.1.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-xstatic-jquery_1.10.2.1.bb2
3 files changed, 26 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-jquery.inc b/meta-openstack/recipes-devtools/python/python-xstatic-jquery.inc
new file mode 100644
index 0000000..db8e2a2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-jquery.inc
@@ -0,0 +1,22 @@
1DESCRIPTION = "jQuery javascript library packaged for setuptools (easy_install) / pip."
2HOMEPAGE = "http://jquery.com/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.txt;md5=af1f21066b501c7d9265fab0d5556ece"
6
7PYPI_PACKAGE = "XStatic-jQuery"
8
9SRC_URI[md5sum] = "7a29efeab6961ef00ea2272c923f4503"
10SRC_URI[sha256sum] = "83416a6bb86e8534858c4d1ddca45e881c87639da6f78000c28c3a193fe91305"
11
12inherit pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 ${PYTHON_PN}-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-jquery_1.10.2.1.bb b/meta-openstack/recipes-devtools/python/python-xstatic-jquery_1.10.2.1.bb
index 3141cf6..23cc65e 100644
--- a/meta-openstack/recipes-devtools/python/python-xstatic-jquery_1.10.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-jquery_1.10.2.1.bb
@@ -1,22 +1,2 @@
1DESCRIPTION = "jQuery javascript library packaged for setuptools (easy_install) / pip." 1require python-xstatic-jquery.inc
2HOMEPAGE = "http://jquery.com/" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.txt;md5=af1f21066b501c7d9265fab0d5556ece"
6
7PYPI_PACKAGE = "XStatic-jQuery"
8
9SRC_URI[md5sum] = "7a29efeab6961ef00ea2272c923f4503"
10SRC_URI[sha256sum] = "83416a6bb86e8534858c4d1ddca45e881c87639da6f78000c28c3a193fe91305"
11
12inherit setuptools pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 python-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python3-xstatic-jquery_1.10.2.1.bb b/meta-openstack/recipes-devtools/python/python3-xstatic-jquery_1.10.2.1.bb
new file mode 100644
index 0000000..efbb9e3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-xstatic-jquery_1.10.2.1.bb
@@ -0,0 +1,2 @@
1require python-xstatic-jquery.inc
2inherit setuptools3