summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2019-12-23 09:21:26 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-12-23 13:13:28 -0500
commit95c73c84156e3c1f8f88800be7671443785e6bbb (patch)
tree1d7cfc4ba0cd6ebf2869ae781c3688d4f18c2c8e /meta-openstack/recipes-devtools
parent17d5fa070f0b88d3b2a1f8033411e4517b5eb564 (diff)
downloadmeta-cloud-services-95c73c84156e3c1f8f88800be7671443785e6bbb.tar.gz
python-pycrypto: Remove the recipe
Because this already exists in meta-openembedded and there is python3 versions in meta-openembedded, Remove the recipe. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch23
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb30
2 files changed, 0 insertions, 53 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch
deleted file mode 100644
index 712f3e8..0000000
--- a/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Index: pycrypto-2.6/setup.py
2===================================================================
3--- pycrypto-2.6.orig/setup.py
4+++ pycrypto-2.6/setup.py
5@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
6 if not os.path.exists("config.status"):
7 if os.system("chmod 0755 configure") != 0:
8 raise RuntimeError("chmod error")
9- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
10+ host = os.environ.get("HOST_SYS")
11+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
12 if self.verbose < 1:
13 cmd += " -q"
14 if os.system(cmd) != 0:
15@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
16 'ext_modules': plat_ext + [
17 # _fastmath (uses GNU mp library)
18 Extension("Crypto.PublicKey._fastmath",
19- include_dirs=['src/','/usr/include/'],
20+ include_dirs=['src/'],
21 libraries=['gmp'],
22 sources=["src/_fastmath.c"]),
23
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb
deleted file mode 100644
index fc91074..0000000
--- a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "Cryptographic modules for Python."
2HOMEPAGE = "http://www.pycrypto.org/"
3SECTION = "devel/python"
4LICENSE = "PSFv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
6
7SRC_URI += " \
8 file://cross-compiling.patch \
9"
10
11SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
12SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
13
14export STAGING_INCDIR
15export STAGING_LIBDIR
16export BUILD_SYS
17export HOST_SYS
18
19inherit autotools autotools-brokensep distutils pypi
20
21DEPENDS += " gmp"
22
23do_compile[noexec] = "1"
24
25# We explicitly call distutils_do_install, since we want it to run, but
26# *don't* want the autotools install to run, since this package doesn't
27# provide a "make install" target.
28do_install() {
29 distutils_do_install
30}