summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-20 15:29:00 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-20 15:29:00 -0400
commit743da013bbbb0f8dfb146986540ff2d9b4627d5e (patch)
tree7fecb7042dafa29467e2c68e36d3e0cc1e6befab /meta-openstack/recipes-devtools
parent6c1c9bde9b96db08e78fecb7aeef6fb5e0fda80a (diff)
downloadmeta-cloud-services-743da013bbbb0f8dfb146986540ff2d9b4627d5e.tar.gz
osprofiler: add os profiling python support
osprofiler is part of the juno glance pipelien processing. So to meet the requirements of glance-api, we introduce the recipe. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb b/meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb
new file mode 100644
index 0000000..7e1fc09
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-osprofiler_0.3.0.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "OpenStack Profiler Library"
2HOMEPAGE = "http://www.openstack.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=19cbd64715b51267a47bf3750cc6a8a5"
6
7PR = "r0"
8
9SRCNAME = "osprofiler"
10SRC_URI = "http://pypi.python.org/packages/source/o/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "519f299f5e6040a9abf8453751225540"
13SRC_URI[sha256sum] = "7d7e1d0b93ce96901f7a307a712196273818a8f20e59916ff099589b48f53207"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 python-six \
28 python-webob \
29 "