summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 15:40:17 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:32 -0500
commit63d42c9c308b53bf23da7f5866fe9b05c64fc2fc (patch)
tree71e10c91ca0c3f31c285b33b3c139b51bce704b9 /meta-openstack/recipes-devtools
parent49d86bc69c0a2ba8718437ffd207902766a50b6b (diff)
downloadmeta-cloud-services-63d42c9c308b53bf23da7f5866fe9b05c64fc2fc.tar.gz
python-xstatic-angular-schema-form: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form.inc22
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form_0.8.13.0.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb2
3 files changed, 26 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form.inc b/meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form.inc
new file mode 100644
index 0000000..7bfa957
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form.inc
@@ -0,0 +1,22 @@
1DESCRIPTION = "Angular Schema Form packaged for setuptools (easy_install) / pip."
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Angular-Schema-Form"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0e4430cb0dfdb98d3008c66d8339f31a"
6
7PYPI_PACKAGE = "XStatic-Angular-Schema-Form"
8
9SRC_URI[md5sum] = "d0faab81c36f4cfc03e092fedc30018d"
10SRC_URI[sha256sum] = "7c08634901751267fe26d266fc027cf6ed2e5f422696985cec750594b3f4e300"
11
12inherit pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 ${PYTHON_PN}-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form_0.8.13.0.bb b/meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form_0.8.13.0.bb
index 5c71b52..25c7626 100644
--- a/meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form_0.8.13.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-angular-schema-form_0.8.13.0.bb
@@ -1,22 +1,2 @@
1DESCRIPTION = "Angular Schema Form packaged for setuptools (easy_install) / pip." 1require python-xstatic-angular-schema-form.inc
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Angular-Schema-Form" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0e4430cb0dfdb98d3008c66d8339f31a"
6
7PYPI_PACKAGE = "XStatic-Angular-Schema-Form"
8
9SRC_URI[md5sum] = "d0faab81c36f4cfc03e092fedc30018d"
10SRC_URI[sha256sum] = "7c08634901751267fe26d266fc027cf6ed2e5f422696985cec750594b3f4e300"
11
12inherit setuptools pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 python-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb b/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb
new file mode 100644
index 0000000..eae97b2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-xstatic-angular-schema-form_0.8.13.0.bb
@@ -0,0 +1,2 @@
1require python-xstatic-angular-schema-form.inc
2inherit setuptools3