diff options
author | Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> | 2019-09-02 20:11:18 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-09-03 15:51:04 -0400 |
commit | 6088220c3eb66ace3e5db0f890787559f3e3a761 (patch) | |
tree | d2f0798ed36f783e74957d5b42f507f6b8c148c9 /meta-openstack/recipes-devtools | |
parent | 849960485830e3a10ccc800ea571329a14a3e42a (diff) | |
download | meta-cloud-services-6088220c3eb66ace3e5db0f890787559f3e3a761.tar.gz |
python-oslo.utils: Python3 version fix
1) Remove 'inherit setuptools' from python-oslo.utils.inc as it was
included in python-oslo.utils_git.bb and python3-oslo.utils_git.bb.
2) Remove RDEPENDS which are not needed for python3.
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-oslo.utils.inc | 4 | ||||
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb | 7 |
2 files changed, 7 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils.inc b/meta-openstack/recipes-devtools/python/python-oslo.utils.inc index 04aa24a..8c3022d 100644 --- a/meta-openstack/recipes-devtools/python/python-oslo.utils.inc +++ b/meta-openstack/recipes-devtools/python/python-oslo.utils.inc | |||
@@ -11,8 +11,6 @@ PV = "3.28.0+git${SRCPV}" | |||
11 | SRCREV = "8b3965b9bbe1e31a4939f2f69c5239d6d5c7f72c" | 11 | SRCREV = "8b3965b9bbe1e31a4939f2f69c5239d6d5c7f72c" |
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | inherit setuptools | ||
15 | |||
16 | # DEPENDS_default: python-pip | 14 | # DEPENDS_default: python-pip |
17 | 15 | ||
18 | DEPENDS += " \ | 16 | DEPENDS += " \ |
@@ -31,11 +29,9 @@ RDEPENDS_${PN} += " \ | |||
31 | ${PYTHON_PN}-six \ | 29 | ${PYTHON_PN}-six \ |
32 | ${PYTHON_PN}-iso8601 \ | 30 | ${PYTHON_PN}-iso8601 \ |
33 | ${PYTHON_PN}-oslo.i18n \ | 31 | ${PYTHON_PN}-oslo.i18n \ |
34 | ${PYTHON_PN}-monotonic \ | ||
35 | ${PYTHON_PN}-pytz \ | 32 | ${PYTHON_PN}-pytz \ |
36 | ${PYTHON_PN}-netaddr \ | 33 | ${PYTHON_PN}-netaddr \ |
37 | ${PYTHON_PN}-netifaces \ | 34 | ${PYTHON_PN}-netifaces \ |
38 | ${PYTHON_PN}-debtcollector \ | 35 | ${PYTHON_PN}-debtcollector \ |
39 | ${PYTHON_PN}-funcsigs \ | ||
40 | ${PYTHON_PN}-pyparsing \ | 36 | ${PYTHON_PN}-pyparsing \ |
41 | " | 37 | " |
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb index fea3c85..1fe6253 100644 --- a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb +++ b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb | |||
@@ -1,2 +1,9 @@ | |||
1 | inherit setuptools | 1 | inherit setuptools |
2 | require python-oslo.utils.inc | 2 | require python-oslo.utils.inc |
3 | |||
4 | # RDEPENDS only for python2 | ||
5 | RDEPENDS_${PN} += " \ | ||
6 | ${PYTHON_PN}-monotonic \ | ||
7 | ${PYTHON_PN}-funcsigs \ | ||
8 | " | ||
9 | |||