summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-08-05 01:11:07 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-07 22:11:26 -0400
commit5b7a11ef832e5df95d98b046ee71771dd126256c (patch)
treec42cc4cf6c0cf456daf70df9f43e9e6d92fd9a63 /meta-openstack/recipes-devtools
parent204b1449666b21457bb895a05931bfbcedcb251c (diff)
downloadmeta-cloud-services-5b7a11ef832e5df95d98b046ee71771dd126256c.tar.gz
python3-swiftclient: change to python3
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>/ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-swiftclient_git.bb35
-rw-r--r--meta-openstack/recipes-devtools/python/python3-swiftclient_3.10.0.bb31
2 files changed, 31 insertions, 35 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb b/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
deleted file mode 100644
index 7a99e8a..0000000
--- a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1DESCRIPTION = "Client library for OpenStack Object Storage API"
2HOMEPAGE = "https://github.com/openstack/python-swiftclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PR = "r0"
8SRCNAME = "swiftclient"
9
10SRC_URI = "git://github.com/openstack/python-swiftclient.git;branch=master"
11
12PV = "3.8.1+git${SRCPV}"
13SRCREV = "72b90fed4c62cf75497a7d66714f5fb0aa91f18b"
14S = "${WORKDIR}/git"
15
16inherit setuptools3 python3-dir
17
18do_install_append() {
19 cp -r tests ${D}/${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/
20}
21
22DEPENDS += " \
23 python-pip \
24 python-pbr \
25 "
26
27# Satisfy setup.py 'setup_requires'
28DEPENDS += " \
29 python-pbr-native \
30 "
31
32RDEPENDS_${PN} += " \
33 python-simplejson \
34 python-pbr \
35 "
diff --git a/meta-openstack/recipes-devtools/python/python3-swiftclient_3.10.0.bb b/meta-openstack/recipes-devtools/python/python3-swiftclient_3.10.0.bb
new file mode 100644
index 0000000..1025d9e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-swiftclient_3.10.0.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Client library for OpenStack Object Storage API"
2HOMEPAGE = "https://github.com/openstack/python-swiftclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PYPI_PACKAGE = "python-swiftclient"
8
9SRC_URI[sha256sum] = "66227eaf29a691c70675fb9982022980b92797c273dd5e6dc7e680425e9a3634"
10
11inherit pypi setuptools3 python3-dir
12
13do_install_append() {
14 cp -r test ${D}/${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/
15}
16
17DEPENDS += " \
18 python3-pip \
19 python3-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python3-pbr-native \
25 "
26
27RDEPENDS_${PN} += " \
28 python3-simplejson \
29 python3-pbr \
30 python3-requests \
31 "