summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 14:32:25 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:38:27 -0500
commit4f88e371c88f8e6c589eb6ab5b482113226cdb33 (patch)
treecb4b367f48ad3f0dcbc0f54c572226fde9fd3557 /meta-openstack/recipes-devtools
parent8ba6f1dbbcbbde2f6b64e11ec16833cc71be6148 (diff)
downloadmeta-cloud-services-4f88e371c88f8e6c589eb6ab5b482113226cdb33.tar.gz
python-glanceclient: uprev to latest stable/pike
Update runtime dependencies based on requirements.txt, drop old patches. Required a downrev of python-warlock as this verison is not compatible with v1.3.0. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch37
-rw-r--r--meta-openstack/recipes-devtools/python/python-glanceclient_git.bb24
2 files changed, 15 insertions, 46 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch
deleted file mode 100644
index 754d83f..0000000
--- a/meta-openstack/recipes-devtools/python/python-glanceclient/fix_glanceclient_memory_leak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1---
2 glanceclient/openstack/common/apiclient/client.py | 10 ++++++++++
3 1 file changed, 10 insertions(+)
4
5--- a/glanceclient/openstack/common/apiclient/client.py
6+++ b/glanceclient/openstack/common/apiclient/client.py
7@@ -90,6 +90,7 @@
8 self.user_agent = user_agent or self.user_agent
9
10 self.times = [] # [("item", starttime, endtime), ...]
11+ self.times_max_len = 200
12 self.timings = timings
13
14 # requests within the same session can reuse TCP connections from pool
15@@ -142,6 +143,12 @@
16 def reset_timings(self):
17 self.times = []
18
19+ def get_timings_max_len(self):
20+ return self.times_max_len
21+
22+ def set_timings_max_len(self, new_len):
23+ self.times_max_len = new_len
24+
25 def request(self, method, url, **kwargs):
26 """Send an http request with the specified characteristics.
27
28@@ -173,6 +180,9 @@
29 if self.timings:
30 self.times.append(("%s %s" % (method, url),
31 start_time, time.time()))
32+ # remove oldest items until we maintain max length
33+ while len(self.times) > self.times_max_len:
34+ del self.times[0]
35 self._http_log_resp(resp)
36
37 if resp.status_code >= 400:
diff --git a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
index 22dc854..00ea2ab 100644
--- a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
@@ -9,12 +9,11 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12SRCREV = "86635868c1eb3aec0c065c12cb9928c613940f36" 12SRCREV = "13b25ff1fed908cfe7b4e719a97efd7121e3be96"
13PV = "1.1.0+git${SRCPV}" 13PV = "2.8.0+git${SRCPV}"
14 14
15SRC_URI = "\ 15SRC_URI = "\
16 git://github.com/openstack/${BPN}.git;protocol=https \ 16 git://github.com/openstack/${BPN}.git;branch=stable/pike \
17 file://fix_glanceclient_memory_leak.patch \
18 file://glance-api-check.sh \ 17 file://glance-api-check.sh \
19 " 18 "
20 19
@@ -29,13 +28,20 @@ DEPENDS += " \
29 python-pbr-native \ 28 python-pbr-native \
30 " 29 "
31 30
32RDEPENDS_${PN} = "gmp \ 31RDEPENDS_${PN} += " \
32 gmp \
33 bash \
34 python-pbr \
35 python-babel \
36 python-prettytable \
37 python-keystoneauth1 \
38 python-requests \
33 python-warlock \ 39 python-warlock \
40 python-six \
41 python-oslo.utils \
42 python-oslo.i18n \
43 python-wrapt \
34 python-pyopenssl \ 44 python-pyopenssl \
35 python-prettytable \
36 python-setuptools-git \
37 python-pbr \
38 bash \
39 " 45 "
40 46
41MONITOR_CHECKS_${PN} += "\ 47MONITOR_CHECKS_${PN} += "\