summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-06-04 09:23:14 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-04 09:23:14 -0400
commit2fdfa2906971d76e8706c6b215d6cf9c2ecacbd8 (patch)
treec314b6569473f5540e12c221fd357c264be739f5 /meta-openstack/recipes-devtools
parent1fb926054190f82c2a24fa7509d0874a365f5ae6 (diff)
downloadmeta-cloud-services-2fdfa2906971d76e8706c6b215d6cf9c2ecacbd8.tar.gz
cephclient: add supporting library python-lxml
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-lxml_3.3.5.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-lxml_3.3.5.bb b/meta-openstack/recipes-devtools/python/python-lxml_3.3.5.bb
new file mode 100644
index 0000000..0fcf152
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-lxml_3.3.5.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2HOMEPAGE = "http://lxml.de/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=%LIC_MD5SUM%"
6
7PR = "r0"
8
9SRCNAME = "lxml"
10SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "88c75f4c73fc8f59c9ebb17495044f2f"
13SRC_URI[sha256sum] = "6ad6949dc7eea744a30fba77a968dd5910f545220e58bcc813b9df5c793e318a"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 python-beautifulsoup4 \
28 python-cssselect \
29 "