summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-17 21:17:11 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-17 21:17:11 -0500
commit0c04811d6805f0d12261fe31e90a40905820ac05 (patch)
tree6da21c99156363fad066e5627bd0bf59050d60ec /meta-openstack/recipes-devtools
parenta027a63237f2f3411f3c444c1b4a2658c8a21933 (diff)
downloadmeta-cloud-services-0c04811d6805f0d12261fe31e90a40905820ac05.tar.gz
horizon: move arch specific RDEPENDS to variables
Assigning to the python-horizon REDENDS in arch specific variables AFTER the main RDEPENDS exposes and issue with bitbake parsing, and we end up with a singular RDEPEND of "nodejs". Assigning to a variable, and using that variable in the main RDEPENDS, fixes the issue. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 281264c..b94d1bf 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -75,6 +75,12 @@ FILES_${SRCNAME} = "${bindir}/* \
75 ${datadir}/* \ 75 ${datadir}/* \
76 " 76 "
77 77
78RDEP_ARCH_VAR = ""
79RDEP_ARCH_VAR_arm = "nodejs"
80RDEP_ARCH_VAR_i686 = "nodejs"
81RDEP_ARCH_VAR_x86-64 = "nodejs"
82RDEP_ARCH_VAR_ia32 = "nodejs"
83
78RDEPENDS_${PN} += " python-django \ 84RDEPENDS_${PN} += " python-django \
79 python-django-appconf \ 85 python-django-appconf \
80 python-django-compressor \ 86 python-django-compressor \
@@ -93,13 +99,9 @@ RDEPENDS_${PN} += " python-django \
93 python-swiftclient \ 99 python-swiftclient \
94 python-lockfile \ 100 python-lockfile \
95 python-pyyaml \ 101 python-pyyaml \
102 ${RDEP_ARCH_VAR} \
96 " 103 "
97 104
98RDEPENDS_${PN}_arm += " nodejs"
99RDEPENDS_${PN}_i686 += " nodejs"
100RDEPENDS_${PN}_x86-64 += " nodejs"
101RDEPENDS_${PN}_ia32 += " nodejs"
102
103RDEPENDS_${SRCNAME} = "${PN}" 105RDEPENDS_${SRCNAME} = "${PN}"
104 106
105INITSCRIPT_PACKAGES = "${SRCNAME}" 107INITSCRIPT_PACKAGES = "${SRCNAME}"