summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 16:30:40 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:32 -0500
commit02fc1c0f429c5798b7509540b970e7594f3adfbc (patch)
treeeeb5f40d6837f42ea708f835de12b911fd4650f8 /meta-openstack/recipes-devtools
parente67e8d50228303089f8b7fbc5a6fec09699c4172 (diff)
downloadmeta-cloud-services-02fc1c0f429c5798b7509540b970e7594f3adfbc.tar.gz
python-xstatic-hogan: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-hogan.inc22
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-hogan_2.0.0.2.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-xstatic-hogan_2.0.0.2.bb2
3 files changed, 26 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-hogan.inc b/meta-openstack/recipes-devtools/python/python-xstatic-hogan.inc
new file mode 100644
index 0000000..deeeae1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-hogan.inc
@@ -0,0 +1,22 @@
1DESCRIPTION = "Hogan JavaScript library packaged for setuptools"
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Hogan"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=18dc983faa3113478ed59ae157a985d5"
6
7PYPI_PACKAGE = "XStatic-Hogan"
8
9SRC_URI[md5sum] = "1c1de09c4813e8568aab98fa5270d6a0"
10SRC_URI[sha256sum] = "5941bc7fb2a09916b8837848e6fc2a13b2dfc271811e9b522c61e1337d5fc2bd"
11
12inherit pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 ${PYTHON_PN}-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-hogan_2.0.0.2.bb b/meta-openstack/recipes-devtools/python/python-xstatic-hogan_2.0.0.2.bb
index aef5706..9d571c5 100644
--- a/meta-openstack/recipes-devtools/python/python-xstatic-hogan_2.0.0.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-hogan_2.0.0.2.bb
@@ -1,22 +1,2 @@
1DESCRIPTION = "Hogan JavaScript library packaged for setuptools" 1require python-xstatic-hogan.inc
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Hogan" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=18dc983faa3113478ed59ae157a985d5"
6
7PYPI_PACKAGE = "XStatic-Hogan"
8
9SRC_URI[md5sum] = "1c1de09c4813e8568aab98fa5270d6a0"
10SRC_URI[sha256sum] = "5941bc7fb2a09916b8837848e6fc2a13b2dfc271811e9b522c61e1337d5fc2bd"
11
12inherit setuptools pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 python-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python3-xstatic-hogan_2.0.0.2.bb b/meta-openstack/recipes-devtools/python/python3-xstatic-hogan_2.0.0.2.bb
new file mode 100644
index 0000000..bdd3c27
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-xstatic-hogan_2.0.0.2.bb
@@ -0,0 +1,2 @@
1require python-xstatic-hogan.inc
2inherit setuptools3