summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 15:55:57 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:32 -0500
commit005d8e96f11c15ab2cf9ef11e960db41578bda11 (patch)
treed57c8ffd3fa934be28c68ad3411767151e620193 /meta-openstack/recipes-devtools
parent50a77c21e5255e58a7fdcea93ce4c1b244d70715 (diff)
downloadmeta-cloud-services-005d8e96f11c15ab2cf9ef11e960db41578bda11.tar.gz
python-xstatic-roboto-fontface: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface.inc19
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface_0.5.0.0.bb21
-rw-r--r--meta-openstack/recipes-devtools/python/python3-xstatic-roboto-fontface_0.5.0.0.bb2
3 files changed, 23 insertions, 19 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface.inc b/meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface.inc
new file mode 100644
index 0000000..d11d0a1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface.inc
@@ -0,0 +1,19 @@
1DESCRIPTION = "A simple package providing the Roboto fontface."
2HOMEPAGE = "https://github.com/choffmeister/roboto-fontface-bower"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7PYPI_PACKAGE = "XStatic-roboto-fontface"
8
9SRC_URI[md5sum] = "32273ba68fa063623461db0b0767524f"
10SRC_URI[sha256sum] = "6d272df58e20eec3a15bca279163f38614c7074e2fecb537a58b29d109e83f62"
11
12inherit pypi
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18RDEPENDS_${PN} += " \
19 "
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface_0.5.0.0.bb b/meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface_0.5.0.0.bb
index 3c828b4..0f52a02 100644
--- a/meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface_0.5.0.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-roboto-fontface_0.5.0.0.bb
@@ -1,19 +1,2 @@
1DESCRIPTION = "A simple package providing the Roboto fontface." 1require python-xstatic-roboto-fontface.inc
2HOMEPAGE = "https://github.com/choffmeister/roboto-fontface-bower" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7PYPI_PACKAGE = "XStatic-roboto-fontface"
8
9SRC_URI[md5sum] = "32273ba68fa063623461db0b0767524f"
10SRC_URI[sha256sum] = "6d272df58e20eec3a15bca279163f38614c7074e2fecb537a58b29d109e83f62"
11
12inherit setuptools pypi
13
14DEPENDS += " \
15 python-pip \
16 "
17
18RDEPENDS_${PN} += " \
19 "
diff --git a/meta-openstack/recipes-devtools/python/python3-xstatic-roboto-fontface_0.5.0.0.bb b/meta-openstack/recipes-devtools/python/python3-xstatic-roboto-fontface_0.5.0.0.bb
new file mode 100644
index 0000000..e05e35e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-xstatic-roboto-fontface_0.5.0.0.bb
@@ -0,0 +1,2 @@
1require python-xstatic-roboto-fontface.inc
2inherit setuptools3