summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-21 09:56:20 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit9643550aa09597778fbbfc30d93987a247f5a63b (patch)
tree3bfd2791e566f9f43490024cf066164e74257105 /meta-openstack/recipes-devtools/ruby
parent52ae70c869d4057d418e3fa031e6521482768d67 (diff)
downloadmeta-cloud-services-9643550aa09597778fbbfc30d93987a247f5a63b.tar.gz
Ruby/chef solo: fixes
Make ruby binaries more accessible by creating symlinks from ${libdir}/ruby/gems/${ruby version}/bin/ to /usr/bin RDEPENDS needs to be package specific coderay needs to depends on yard Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/chef-zero_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/coderay_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/ohai_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/rest-client_git.bb2
8 files changed, 8 insertions, 7 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
index 7e8701d..1d8a240 100644
--- a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
@@ -28,7 +28,7 @@ SRC_URI = " \
28 28
29inherit ruby 29inherit ruby
30 30
31RDEPENDS += " \ 31RDEPENDS_${PN} += " \
32 mixlib-log \ 32 mixlib-log \
33 json \ 33 json \
34 hashie \ 34 hashie \
diff --git a/meta-openstack/recipes-devtools/ruby/coderay_git.bb b/meta-openstack/recipes-devtools/ruby/coderay_git.bb
index cbb743c..3253699 100644
--- a/meta-openstack/recipes-devtools/ruby/coderay_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/coderay_git.bb
@@ -24,3 +24,4 @@ inherit ruby
24RUBY_COMPILE_FLAGS += "RELEASE=1" 24RUBY_COMPILE_FLAGS += "RELEASE=1"
25 25
26BBCLASSEXTEND = "native" 26BBCLASSEXTEND = "native"
27DEPENDS += "yard"
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
index eb152e8..b380e01 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
@@ -22,7 +22,7 @@ SRC_URI = " \
22 22
23inherit ruby 23inherit ruby
24 24
25RDEPENDS += " \ 25RDEPENDS_${PN} += " \
26 mixlib-log \ 26 mixlib-log \
27 " 27 "
28 28
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
index 7c46b5a..b823a03 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
26 26
27inherit ruby 27inherit ruby
28 28
29RDEPENDS += " \ 29RDEPENDS_${PN} += " \
30 net-ssh \ 30 net-ssh \
31 " 31 "
32 32
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
index 11527be..86f2807 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
26 26
27inherit ruby 27inherit ruby
28 28
29RDEPENDS += " \ 29RDEPENDS_${PN} += " \
30 net-ssh \ 30 net-ssh \
31 net-ssh-gateway \ 31 net-ssh-gateway \
32 " 32 "
diff --git a/meta-openstack/recipes-devtools/ruby/ohai_git.bb b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
index 3dbfe00..6bd31e1 100644
--- a/meta-openstack/recipes-devtools/ruby/ohai_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
@@ -25,7 +25,7 @@ SRC_URI = " \
25 25
26inherit ruby 26inherit ruby
27 27
28RDEPENDS += " \ 28RDEPENDS_${PN} += " \
29 mime-types \ 29 mime-types \
30 ipaddress \ 30 ipaddress \
31 mixlib-cli \ 31 mixlib-cli \
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
index 91e3c43..2dc6234 100644
--- a/meta-openstack/recipes-devtools/ruby/pry_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -26,7 +26,7 @@ inherit ruby
26 26
27RUBY_COMPILE_FLAGS = "" 27RUBY_COMPILE_FLAGS = ""
28 28
29RDEPENDS += " \ 29RDEPENDS_${PN} += " \
30 coderay \ 30 coderay \
31 method-source \ 31 method-source \
32 slop \ 32 slop \
diff --git a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
index 9d31e65..0b79cfe 100644
--- a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
@@ -23,7 +23,7 @@ SRC_URI = " \
23 23
24inherit ruby 24inherit ruby
25 25
26RDEPENDS += " \ 26RDEPENDS_${PN} += " \
27 mime-types \ 27 mime-types \
28 " 28 "
29 29