summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:17:16 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:13 -0400
commit819a4f24d61c451aea7d4cc21644cea79a8c41bb (patch)
tree03c148b0bc09582410723ed5e4fc1c9f3184adbb /meta-openstack/recipes-devtools/ruby
parenta73e2390a5d48ac74655098d3bba6afd8aeea14f (diff)
downloadmeta-cloud-services-819a4f24d61c451aea7d4cc21644cea79a8c41bb.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/chef-zero_git.bb
Chef Zero is a simple, easy-install, in-memory Chef server that can be useful for Chef Client testing and chef-solo-like tasks that require a full Chef Server. It IS intended to be simple, Chef 11 compliant, easy to run and fast to start. It is NOT intended to be secure, scalable, performant or persistent. It does NO input validation, authentication or authorization (it will not throw a 400, 401 or 403). It does not save data, and will start up empty each time you start it. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/chef-zero_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
new file mode 100644
index 0000000..7e8701d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
@@ -0,0 +1,39 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Chef server that can be useful for chef-solo-like tasks"
5DESCRIPTION = "Chef Zero is a simple, easy-install, in-memory Chef \
6server that can be useful for Chef Client testing and chef-solo-like \
7tasks that require a full Chef Server. It IS intended to be simple, \
8Chef 11 compliant, easy to run and fast to start. It is NOT intended \
9to be secure, scalable, performant or persistent. It does NO input \
10validation, authentication or authorization (it will not throw a 400, \
11401 or 403). It does not save data, and will start up empty each time \
12you start it."
13
14LICENSE = "Apache-2.0"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
16
17PR = "r0"
18
19BPV = "2.0.2"
20PV = "${BPV}"
21SRCREV = "1c87a463637b3d0c58755e2362cc8ef35b6da1fd"
22
23S = "${WORKDIR}/git"
24
25SRC_URI = " \
26 git://github.com/opscode/chef-zero.git \
27 "
28
29inherit ruby
30
31RDEPENDS += " \
32 mixlib-log \
33 json \
34 hashie \
35 mixlib-log \
36 rack \
37 "
38
39BBCLASSEXTEND = "native"