summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-07-28 17:50:04 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-07-29 11:12:07 -0400
commit4ae6d06ad7e37f1ab8b44007349d2121173fcb81 (patch)
tree49e5e1deb7e5636fd846bd6f091c21a11ad27e09 /meta-openstack/recipes-devtools/ruby
parente3371b8e24fdca5c7a5e9fed0c4b2abc8693bd13 (diff)
downloadmeta-cloud-services-4ae6d06ad7e37f1ab8b44007349d2121173fcb81.tar.gz
pry: upgrade 0.9.12.6 -> 0.10.1
1) Modify rdoc-fixup-opt.banner-heredoc.patch,since the contents has been changed. 2) Update the checksum of LICENSE,since the date in it has been changed, but the LICENSE has not been changed. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch56
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb8
2 files changed, 33 insertions, 31 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch b/meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch
index b6612c9..32adfb6 100644
--- a/meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch
+++ b/meta-openstack/recipes-devtools/ruby/pry/rdoc-fixup-opt.banner-heredoc.patch
@@ -1,6 +1,6 @@
1From 55f81df0bb27c68d2a817cade5e0eb472acf24e5 Mon Sep 17 00:00:00 2001 1From 40f78c9ae1c8f37e382d2da3498e1670c1a321dd Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com> 2From: Li xin <lixin.fnst@cn.fujitsu.com>
3Date: Wed, 14 May 2014 10:43:04 -0400 3Date: Sat, 25 Jul 2015 03:13:50 +0900
4Subject: [PATCH] rdoc: fixup opt.banner heredoc 4Subject: [PATCH] rdoc: fixup opt.banner heredoc
5 5
6rdoc has some quirks with heredoc which in this case would 6rdoc has some quirks with heredoc which in this case would
@@ -13,39 +13,41 @@ Fixup the heredoc to use a more standard format which is known
13not to mess up rdoc processing. 13not to mess up rdoc processing.
14 14
15Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 15Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
16Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
16--- 17---
17 lib/pry/commands/ls.rb | 34 +++++++++++++++++----------------- 18 lib/pry/commands/ls.rb | 35 ++++++++++++++++-------------------
18 1 file changed, 17 insertions(+), 17 deletions(-) 19 1 file changed, 16 insertions(+), 19 deletions(-)
19 20
20diff --git a/lib/pry/commands/ls.rb b/lib/pry/commands/ls.rb 21diff --git a/lib/pry/commands/ls.rb b/lib/pry/commands/ls.rb
21index 6ce49bb..b78f7e1 100644 22index 9f0e68f..eda7a53 100644
22--- a/lib/pry/commands/ls.rb 23--- a/lib/pry/commands/ls.rb
23+++ b/lib/pry/commands/ls.rb 24+++ b/lib/pry/commands/ls.rb
24@@ -6,23 +6,23 @@ class Pry 25@@ -28,25 +28,22 @@ class Pry
26 description 'Show the list of vars and methods in the current scope.'
25 command_options :shellwords => false, :interpolate => false 27 command_options :shellwords => false, :interpolate => false
26 28
27 def options(opt) 29- banner <<-'BANNER'
28- opt.banner unindent <<-'BANNER' 30- Usage: ls [-m|-M|-p|-pM] [-q|-v] [-c|-i] [Object]
29- Usage: ls [-m|-M|-p|-pM] [-q|-v] [-c|-i] [Object] 31- ls [-g] [-l]
30- ls [-g] [-l] 32-
33- ls shows you which methods, constants and variables are accessible to Pry. By
34- default it shows you the local variables defined in the current shell, and any
35- public methods or instance variables defined on the current object.
31- 36-
32- ls shows you which methods, constants and variables are accessible to Pry. By 37- The colours used are configurable using Pry.config.ls.*_color, and the separator
33- default it shows you the local variables defined in the current shell, and any 38- is Pry.config.ls.separator.
34- public methods or instance variables defined on the current object.
35- 39-
36- The colours used are configurable using Pry.config.ls.*_color, and the separator 40- Pry.config.ls.ceiling is used to hide methods defined higher up in the
37- is Pry.config.ls.separator. 41- inheritance chain, this is by default set to [Object, Module, Class] so that
42- methods defined on all Objects are omitted. The -v flag can be used to ignore
43- this setting and show all methods, while the -q can be used to set the ceiling
44- much lower and show only methods defined on the object or its direct class.
38- 45-
39- Pry.config.ls.ceiling is used to hide methods defined higher up in the 46- Also check out `find-method` command (run `help find-method`).
40- inheritance chain, this is by default set to [Object, Module, Class] so that 47- BANNER
41- methods defined on all Objects are omitted. The -v flag can be used to ignore 48+ opt.banner = <<-EOF
42- this setting and show all methods, while the -q can be used to set the ceiling
43- much lower and show only methods defined on the object or its direct class.
44- BANNER
45+ opt.banner = <<-EOF
46+Usage: ls [-m|-M|-p|-pM] [-q|-v] [-c|-i] [Object] 49+Usage: ls [-m|-M|-p|-pM] [-q|-v] [-c|-i] [Object]
47+ ls [-g] [-l] 50+ ls [-g] [-l]
48+
49+ls shows you which methods, constants and variables are accessible to Pry. By 51+ls shows you which methods, constants and variables are accessible to Pry. By
50+default it shows you the local variables defined in the current shell, and any 52+default it shows you the local variables defined in the current shell, and any
51+public methods or instance variables defined on the current object. 53+public methods or instance variables defined on the current object.
@@ -60,8 +62,8 @@ index 6ce49bb..b78f7e1 100644
60+much lower and show only methods defined on the object or its direct class. 62+much lower and show only methods defined on the object or its direct class.
61+ EOF 63+ EOF
62 64
63 opt.on :m, :methods, "Show public methods defined on the Object (default)" 65
64 opt.on :M, "instance-methods", "Show methods defined in a Module or Class" 66 def options(opt)
65-- 67--
661.8.3.2 681.8.4.2
67 69
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
index 37d4497..a4eb63c 100644
--- a/meta-openstack/recipes-devtools/ruby/pry_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -7,18 +7,18 @@ for Ruby. It is written from scratch to provide a number of advanced \
7features." 7features."
8 8
9LICENSE = "MIT" 9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=7d1a6fbb73f604e1e716380490938bd4" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=dde93753687e16ab0c4669232fd27fd0"
11 11
12PR = "r0" 12PR = "r0"
13 13
14BPV = "0.9.12.6" 14BPV = "0.10.1"
15PV = "${BPV}" 15PV = "${BPV}"
16SRCREV = "047788c4225b25bb0462e06715616964e4f0da15" 16SRCREV = "191dc519813402acd6db0d7f73e652ed61f8111f"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20SRC_URI = " \ 20SRC_URI = " \
21 git://github.com/pry/pry.git;branch=0-9-12-stable \ 21 git://github.com/pry/pry.git \
22 file://rdoc-fixup-opt.banner-heredoc.patch \ 22 file://rdoc-fixup-opt.banner-heredoc.patch \
23 " 23 "
24 24